Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

SOLVED - “Error: Please check for sufficient write file permissions”
 
aidanodr
Jr. Member
 
Total Posts:  1
Joined:  2009-06-10
 

Hi Guys,

First this is a guarded SOLVED in that I do not have SSH, I am on a shared host platform and Linux. These conditions being met by others, this is what i did:

1) I followed the initial install proceedure and the particular permissions one had to apply to certain folders.

2) I then found this BLOG entry -

http://till.klampaeckel.de/blog/archives/29-Magento-Error-Please-check-for-sufficient-write-file-permissions.html

Which states:

here’s a list of files and directories that need to be made writable so Magento Connect gets to work:

/path/to/your/magento-install

/path/to/your/magento-install/downloader

/path/to/your/magento-install/downloader/config.ini

/path/to/your/magento-install/downloader/pearlib/config.ini

/path/to/your/magento-install/downloader/pearlib/pear.ini

/path/to/your/magento-install/downloader/pearlib/php

3) This allowed me into Magento Connect

4) I copy / pasted the EXTENSION KEY into the supplied field and hit INSTALL

5) I then scrolled down to the CONSOLE WINDOW at the bottom of the Magento Connect page. Here pay attention to some directories / files it needs to be writeable. In my case these were inside the SKIN/FRONTEND folder and the APP/DESIGN Folder. Once you apply the appropriate permissions ( 777?? ) to these folders, then hit the INSTALL button up top again.

6) Now it should say “install ok: .... “ in the console.

7) To enable the new theme ( as was my case ) - Go to the SYSTEM Menu, Configuration. Over left select the DEFAULT STORE View under the “Current Configuration Scope:” drop box. Down left menu tabs select DESIGN. On the right expand THEMES, untick the USE WEBSITE items to the right of both the Layout and Default Fields. Write the name of the theme into these fields, in my case it was “blank”. SAVE the config.

HOPEFULLY now all should be well ...

Please leave comments generally, but particularly if successful, making sure the proceedure is OK.

Cheers
Aidan

 
Magento Community Magento Community
Magento Community
Magento Community
 
Zella
Jr. Member
 
Total Posts:  8
Joined:  2009-07-22
UK
 

thank you thank you thank you!

After several hours reading through posts and trying various methods without success I used your idea and it let me in first time!

May you live long and prosper! smile

 
Magento Community Magento Community
Magento Community
Magento Community
 
mbartens@gmail.com
Jr. Member
 
Total Posts:  14
Joined:  2009-02-26
 

THANK YOU!!!!!!!!!!!!!!!!!!!!!!!!

 
Magento Community Magento Community
Magento Community
Magento Community
 
WebhostUK LTD
Sr. Member
 
Avatar
Total Posts:  163
Joined:  2009-08-27
UK
 

I will like to add one more point for security reasons most of the host now a days have suphp installed on their share servers..In that case 777 permission for folder wont work ..you will still get error.

Make sure you have 755 for folder and 644 for files under those folder.

Suphp is important to avoid hack attempts and false script upload under 777 folders under your site.

Hope this add up to your article.. By the way thank you for the good explanation to resolve this issue.

 
Magento Community Magento Community
Magento Community
Magento Community
 
zappa
Jr. Member
 
Total Posts:  3
Joined:  2009-06-03
 

Had the same problem, thank you!

 
Magento Community Magento Community
Magento Community
Magento Community
 
lmw1
Jr. Member
 
Total Posts:  19
Joined:  2007-12-19
 

Worked like a charm. Thank you!

 
Magento Community Magento Community
Magento Community
Magento Community
 
sahuspilwal
Member
 
Avatar
Total Posts:  37
Joined:  2009-08-02
Hastings, United Kingdom
 

Changing permissions to 777 for my root web folder fixed it for me. So just make sure you do that before you pull your hair out wink

I was close to CHMOD\’ing the entire Magento root directory but got in after doing the above. Hope this helps somebody.

Cheers, Sahus

 
Magento Community Magento Community
Magento Community
Magento Community
 
Nikul
Jr. Member
 
Avatar
Total Posts:  22
Joined:  2008-11-04
 

May this help:

https://www.gigapros.com/support/index.php?_m=knowledgebase&_a=viewarticle&kbarticleid;=164

 
Magento Community Magento Community
Magento Community
Magento Community
 
petednik
Jr. Member
 
Total Posts:  1
Joined:  2008-10-23
 

Thank you very much, Your solution works wink

 
Magento Community Magento Community
Magento Community
Magento Community
 
thesun4you
Jr. Member
 
Total Posts:  11
Joined:  2009-03-14
 

All of my permissions are correct but still magento connect doesn’t work through the admin. I get a 404 error what’s going on with that. Is there another way.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Nikul
Jr. Member
 
Avatar
Total Posts:  22
Joined:  2008-11-04
 

@thesun4you:

404 error means even you don’t have ‘Downloader” folder in your magento. Please check “Downloader” folder on your magento root otherwise you can get it from www.magentocommerce.com by downloading appropriate version of your magento.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Jamey Warren
Jr. Member
 
Total Posts:  3
Joined:  2010-07-09
 

Worked for me too.  Thank You!

 
Magento Community Magento Community
Magento Community
Magento Community
 
wowpro
Jr. Member
 
Total Posts:  10
Joined:  2010-11-24
 

That calls for toast.... Cheers.

Note:
For me
Changing the permission to 777 for root folder; did not change the permissions to sub n sub n sub folders in cpanel.....that bugs.......

 
Magento Community Magento Community
Magento Community
Magento Community
 
ggchamp
Sr. Member
 
Total Posts:  153
Joined:  2009-04-30
 
aidanodr - 01 July 2009 09:22 AM

Hi Guys,

First this is a guarded SOLVED in that I do not have SSH, I am on a shared host platform and Linux. These conditions being met by others, this is what i did:

1) I followed the initial install proceedure and the particular permissions one had to apply to certain folders.

2) I then found this BLOG entry -

http://till.klampaeckel.de/blog/archives/29-Magento-Error-Please-check-for-sufficient-write-file-permissions.html

Which states:

here’s a list of files and directories that need to be made writable so Magento Connect gets to work:

/path/to/your/magento-install

/path/to/your/magento-install/downloader

/path/to/your/magento-install/downloader/config.ini

/path/to/your/magento-install/downloader/pearlib/config.ini

/path/to/your/magento-install/downloader/pearlib/pear.ini

/path/to/your/magento-install/downloader/pearlib/php

3) This allowed me into Magento Connect

4) I copy / pasted the EXTENSION KEY into the supplied field and hit INSTALL

5) I then scrolled down to the CONSOLE WINDOW at the bottom of the Magento Connect page. Here pay attention to some directories / files it needs to be writeable. In my case these were inside the SKIN/FRONTEND folder and the APP/DESIGN Folder. Once you apply the appropriate permissions ( 777?? ) to these folders, then hit the INSTALL button up top again.

6) Now it should say “install ok: .... “ in the console.

7) To enable the new theme ( as was my case ) - Go to the SYSTEM Menu, Configuration. Over left select the DEFAULT STORE View under the “Current Configuration Scope:” drop box. Down left menu tabs select DESIGN. On the right expand THEMES, untick the USE WEBSITE items to the right of both the Layout and Default Fields. Write the name of the theme into these fields, in my case it was “blank”. SAVE the config.

HOPEFULLY now all should be well ...

Please leave comments generally, but particularly if successful, making sure the proceedure is OK.

Cheers
Aidan

I like this solution as opposed to just making your entire sire 777 which is insane, on production sites i just use the SSH solution which seems most secure.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top