Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Magento installation errors in XAMPP 1.8.2 beta version
 
ssbhati
Jr. Member
 
Total Posts:  13
Joined:  2013-06-03
India
 

Replace in file app/code/core/Mage/Install/etc/config.xml (near 71th string) this

<extensions>
    <
pdo_mysql/>
</
extensions>

with this
<extensions>
    <
pdo_mysql>1</pdo_mysql>
</
extensions>

Line 59 of the file app/code/core/Mage/Install/Model/Installer/Db/Mysql4.php
Replace:

public function supportEngine()
    
{
        $variables  
$this->_getConnection()
            ->
fetchPairs('SHOW VARIABLES');
        return (!isset(
$variables['have_innodb']) || $variables['have_innodb'!= 'YES') ? false true;
    
}
with this:
public function supportEngine()
    
{
        $variables  
$this->_getConnection()
            ->
fetchPairs('SHOW ENGINES');
        return (isset(
$variables['InnoDB']) && $variables['InnoDB'!= 'NO');
    
}
 
Magento Community Magento Community
Magento Community
Magento Community
 
jordipuig
Jr. Member
 
Total Posts:  12
Joined:  2013-05-21
 

This issue is caused by the change of INNODB variable in newer versions of MySQL, and should be fixed by magento guys.... If you know that you have support for Innodb, you can just make the function return true.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top