Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

The Definitive .htaccess for 1 and 1 Hosting
 
PCGamesPlus
Sr. Member
 
Avatar
Total Posts:  166
Joined:  2008-01-03
Sacramento, CA
 

I use 1 and 1 hosting and have just installed the latest beta. Everything seems to be working OK right now. I was wondering if somebody could take a look at my .htaccess file and tell me if anything is missing or should set it up differently to optimize the performance of Magento with this webhost. Thanks

############################################
## uncomment these lines for CGI mode
## make sure to specify the correct cgi php binary file name
## it might be /cgi-bin/php-cgi

#    Action php5-cgi /cgi-bin/php5-cgi
#    AddHandler php5-cgi .php
#    php_flag cgi.fix_pathinfo on

############################################
## this line is specific for 1and1 hosting

    AddType x-mapp-php5 .php
    AddHandler x
-mapp-php5 .php

############################################
## default index file

    
DirectoryIndex index.php

<IfModule mod_php5.c>

############################################
## adjust memory limit

    
php_value memory_limit 40M
    php_value max_execution_time 18000

############################################
## disable magic quotes for php request vars

    
php_flag magic_quotes_gpc off

############################################
## enable resulting html compression

    #php_flag zlib.output_compression on

</IfModule>

<
IfModule mod_deflate.c>

############################################
## enable apache served files compression
## http://developer.yahoo.com/performance/rules.html#gzip

    # Insert filter
    
SetOutputFilter DEFLATE

    
# Netscape 4.x has some problems...
    
BrowserMatch ^Mozilla/4 gzip-only-text/html

    
# Netscape 4.06-4.08 have some more problems
    
BrowserMatch ^Mozilla/4\.0[678] no-gzip

    
# MSIE masquerades as Netscape, but it is fine
    
BrowserMatch \bMSIE !no-gzip !gzip-only-text/html
    
# Don't compress images
    
SetEnvIfNoCase Request_URI \
    \
.(?:gif|jpe?g|png)$ no-gzip dont-vary

    
# Make sure proxies don't deliver the wrong content
    
Header append Vary User-Agent env=!dont-vary

</IfModule>

<
IfModule mod_ssl.c>

############################################
## make HTTPS env vars available for CGI mode

    
SSLOptions StdEnvVars

</IfModule>

<
IfModule mod_rewrite.c>

############################################
## enable rewrites

    
Options +FollowSymLinks
    RewriteEngine on

############################################
## you can put here your magento root folder
## path relative to web root

    
RewriteBase /

############################################
## workaround for HTTP authorization
## in CGI environment

    
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

############################################
## always send 404 on missing files in these folders

    
RewriteCond %{REQUEST_URI} !^/(media|skin|js)/

############################################
## never rewrite for existing files, directories and links

    
RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond 
%{REQUEST_FILENAME} !-d
    RewriteCond 
%{REQUEST_FILENAME} !-l

############################################
## rewrite everything else to index.php

    
RewriteRule .* index.php [L]

</IfModule>


############################################
## Prevent character encoding issues from server overrides
## If you still have problems, use the second line instead

    
AddDefaultCharset Off
    
#AddDefaultCharset UTF-8

<IfModule mod_expires.c>

############################################
## Add default Expires header
## http://developer.yahoo.com/performance/rules.html#expires

    
ExpiresDefault "access plus 1 year"

</IfModule>

############################################
## By default allow all access

    
Order allow,deny
    Allow from all

############################################
## If running in cluster environment, uncomment this
## http://developer.yahoo.com/performance/rules.html#etags

    #FileETag none

It installed OK, although it stalled at the download beta packages screen and had to do the “/wizard/config” trick to get it to finish.
Thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
Airforce111
Sr. Member
 
Avatar
Total Posts:  100
Joined:  2008-01-31
 

4Alarm, that’s almost identical to what I have on one of my 1&1;shared hosting servers.

Personally, I added/changed the following:

This still gives me access to PHP4 (if I ever need it)
AddType x-mapp-php .php4
AddType x-mapp-php5 .php
AddHandler x-mapp-php .php4
AddHandler x-mapp-php5 .php

1&1;’s PHP default max_execution_time is actually longer at 50s.
php_value max_execution_time 18000 to php_value max_execution_time 50000

The default for memory_limit is 40M for 1&1;and I see you already upped it to that value. so, looks good. I can’t find anything not working unless it’s a bug… so if you can’t find anything either, it should be solid. smile

 
Magento Community Magento Community
Magento Community
Magento Community
 
PCGamesPlus
Sr. Member
 
Avatar
Total Posts:  166
Joined:  2008-01-03
Sacramento, CA
 

Thanks for the input I’ll make those changes that you recommended and see how it goes.

Thanks alot

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top