Magento Forum

Magento Connect Error
 
leebah
Jr. Member
 
Total Posts:  1
Joined:  2012-07-17
 

When I try to use Magento Connect Manager to check for updates, I get:

Exception caught: Warning: Invalid argument supplied for foreach() in /home/thedream/public_html/downloader/Maged/Model/Pear.php on line 142 Backtrace: #0 /home/thedream/public_html/downloader/Maged/Model/Pear.php(142): mageCoreErrorHandler(2, ‘Invalid argumen...’, ‘/home/thedream/...’, 142, Array) #1 /home/thedream/public_html/downloader/template/pear/packages.phtml(49): Maged_Model_Pear->getAllPackages() #2 /home/thedream/public_html/downloader/Maged/View.php(59): include(’/home/thedream/...’) #3 /home/thedream/public_html/downloader/Maged/Controller.php(113): Maged_View->template(’pear/packages.p...’) #4 /home/thedream/public_html/downloader/Maged/Controller.php(355): Maged_Controller->pearPackagesAction() #5 /home/thedream/public_html/downloader/Maged/Controller.php(170): Maged_Controller->dispatch() #6 /home/thedream/public_html/downloader/index.php(35): Maged_Controller::run() #7 {main}

Any ideas? Helping someone try to upgrade their site from version 1.3.2.4 and I’m trying to find the easiest way possible.

 
Magento Community Magento Community
Magento Community
Magento Community
 
cinemaduro
Member
 
Avatar
Total Posts:  53
Joined:  2008-06-04
North Carolina, USA
 

I’m doing this same thing (trying to upgrade from version 1.3.2.4) and encountering the same error when checking for updates in Magento Connect. Help, please smile

Running PHP V. 5.3.26

PS: the captcha on this forum is terrible.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top