Magento Forum

Fatal error (fixxed) / new problem.. links won’t work
 
Theuntje
Jr. Member
 
Total Posts:  5
Joined:  2008-01-21
 

Hi.. for some time now i am trying to make Magento work on a server (not mine cause i don’t have the right php).

Anyhow.. Finally i got thru the installation pages.. i was so happy jumping up and down on my seat.. well not for long.. cause when i wen to the frontpage i got nice error messages:

http://neptune.multiserve.nl/~theun/index.php/

Can anyone help me? I do have al the PHP modules (http://neptune.multiserve.nl/~theun/php.php) please help me.. i don’t know the exact server statics.. but it is an linux rasberry..

 
Magento Community Magento Community
Magento Community
Magento Community
 
Theuntje
Jr. Member
 
Total Posts:  5
Joined:  2008-01-21
 

So i have uploaded the entire package again.. And now i am ride of those 2 fatal errors but now i have some other errors
http://neptune.multiserve.nl/~theun/

 
Magento Community Magento Community
Magento Community
Magento Community
 
Theuntje
Jr. Member
 
Total Posts:  5
Joined:  2008-01-21
 

Got some server info

-Debian
-php5
-apache 2

First i had fatal errors then i re-uploaded it and then i got this messege:

exception 'Mage_Core_Exception' with message 'Can't retrieve entity configcms/page_store' in /home/theun/public_html/app/Mage.php:377
Stack trace:
#0 /home/theun/public_html/app/code/core/Mage/Core/Model/Resource.php(133): Mage::throwException('
Can't retrieve ...')
#1 /home/theun/public_html/app/code/core/Mage/Core/Model/Mysql4/Abstract.php(218): Mage_Core_Model_Resource->getTableName('cms/page_store')
#2 /home/theun/public_html/app/code/core/Mage/Cms/Model/Mysql4/Page.php(99): Mage_Core_Model_Mysql4_Abstract->getTable('cms/page_store')
#3 /home/theun/public_html/app/code/core/Mage/Core/Model/Mysql4/Abstract.php(303): Mage_Cms_Model_Mysql4_Page->_afterLoad(Object(Mage_Cms_Model_Page))
#4 /home/theun/public_html/app/code/core/Mage/Cms/Model/Mysql4/Page.php(89): Mage_Core_Model_Mysql4_Abstract->load(Object(Mage_Cms_Model_Page), 'home', 'identifier')
#5 /home/theun/public_html/app/code/core/Mage/Core/Model/Abstract.php(193): Mage_Cms_Model_Mysql4_Page->load(Object(Mage_Cms_Model_Page), 'home', NULL)
#6 /home/theun/public_html/app/code/core/Mage/Cms/Model/Page.php(43): Mage_Core_Model_Abstract->load('home', NULL)
#7 /home/theun/public_html/app/code/core/Mage/Cms/Helper/Page.php(41): Mage_Cms_Model_Page->load('home')
#8 /home/theun/public_html/app/code/core/Mage/Cms/controllers/IndexController.php(26): Mage_Cms_Helper_Page->renderPage(Object(Mage_Cms_IndexController), 'home')
#9 /home/theun/public_html/app/code/core/Mage/Core/Controller/Varien/Action.php(341): Mage_Cms_IndexController->indexAction()
#10 /home/theun/public_html/app/code/core/Mage/Core/Controller/Varien/Router/Standard.php(150): Mage_Core_Controller_Varien_Action->dispatch('index')
#11 /home/theun/public_html/app/code/core/Mage/Core/Controller/Varien/Front.php(147): Mage_Core_Controller_Varien_Router_Standard->match(Object(Mage_Core_Controller_Request_Http))
#12 /home/theun/public_html/app/Mage.php(421): Mage_Core_Controller_Varien_Front->dispatch()
#13 /home/theun/public_html/index.php(29): Mage::run('default')
#14 {main}
 
Magento Community Magento Community
Magento Community
Magento Community
 
Michae1
Enthusiast
 
Total Posts:  826
Joined:  2007-08-31
 

Hi Theuntje,

Did you try to clean the cache (i.e. deleting var/cache folder in your Magento installation) ?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Theuntje
Jr. Member
 
Total Posts:  5
Joined:  2008-01-21
 

I just did.. And it works now.. Thank you very mucho mister Michael

Sh*t.. But now.. none of the links are working.. nothing is there is seems.. I Get messages that there are no such files or directories

example: http://neptune.multiserve.nl/~theun/wishlist/

 
Magento Community Magento Community
Magento Community
Magento Community
 
Michae1
Enthusiast
 
Total Posts:  826
Joined:  2007-08-31
 
Theuntje - 23 March 2008 04:29 AM

But now.. none of the links are working.. nothing is there is seems.. I Get messages that there are no such files or directories

example: http://neptune.multiserve.nl/~theun/wishlist/

It looks like your server doesn’t have mod_rewrite working. Please go to System -> Configuration -> tab Web and set ‘Use Web Server Rewrites’ to ‘No’ under ‘Search Engines Optimization’ section

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top