Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

INVALID POST DATA in ver 1.3.2.1
 
JoshMcGrath
Jr. Member
 
Total Posts:  15
Joined:  2009-06-13
Atlanta, GA
 

So I’ve exhausted every post in the forums regarding this error and I have not found a solution.

When trying to install any extension in Magento Connect manager, I get the error “INVALID POST DATA.”

I do not see any extensions installed when first logging into connect manager and have tried dozens of different extensions to see if any of them work.

I have played with every file permission setting possible and none of the settings, i.e. 644 for files, 755 for directories. I’ve called my hosting company to see if they see any actions that are being blocked by the server or firewalls and everything looks fine from their end.  I am running Magento 1.3.2.1

For fun, I edited the /downloader/Maged/Controller.php file to include a different line where the script is running into errors with the following code lines - 122-127

public function pearInstallPackagePostAction()
    
{
        
if (!$_POST{
            
echo "INVALID POST DATA-125";
            return;
        
}
and on lines 139-146
public function distUpgradePostAction()
    
{
        
if (!$_POST{
            
echo "INVALID POST DATA-142";
            return;
        
}
        $result 
$this->model('pear'true)->distUpgrade($_POST['version']);
    
}
Now when I run any extension I see “INVALID POST DATA-125” which leads me to believe that there is an issue with the pearInstallPackagePostAction() function.

I have also tried reinstalling Magento several times and the same problem exists “Invalid Post Data”. One odd point is that there was no directory “/app/code/community” or “/app/code/local” created with any install attempt and I had to manually create them. That may or may not be related to the issue but I wanted to throw it out there.

The rest of the store (frontend and backend) works beautifully. Here are the program versions that I am using:

Program Version
Apache: 2.2.11
CentOS: .
cPanel: 11.24.4-RELEASE
Curl: 7.12.1
MySQL 5.1.30
phpMyAdmin 2.11.9.5
Python: 2.4.3

Program Version
Perl: 5.8.8
PHP: 5.2.5
ionCube Loader: 3.1.34
Zend Optimizer: 3.3.3
Ruby: 1.8.7
Rails: 2.2.2
OpenSSL: 0.9.8e-fips-rhel5

Does anyone have any suggestions or other posts that I could check for an answer?

 
Magento Community Magento Community
Magento Community
Magento Community
 
JoshMcGrath
Jr. Member
 
Total Posts:  15
Joined:  2009-06-13
Atlanta, GA
 

Just an update- this problem does seem to be related to file permissions.

I initially tried to fix the file permissions with both FireZilla using “file permissions” and checking the recursive option and my host’s built in file manager but for some reason, neither option worked.

So I called my host and asked them to allow me SSH access and i tried the steps listed here:
http://www.magentocommerce.com/wiki/groups/227/resetting_file_permissions

This fixed the problems and I can now install different modules and also upgraded to ver 1.3.2.2 this morning without problem.  Make sure you’re in the root directory (where your index.php file is located) when you run these commands.

 
Magento Community Magento Community
Magento Community
Magento Community
 
louy
Jr. Member
 
Total Posts:  3
Joined:  2009-07-16
 

This may be dangerous security-wise, but I made the entire directory “downloader” and its contents (recursively - easy using CyberDuck) permission 777. Then I began to install the package and the INVALID POST DATA error was removed and I step by step changed permissions for subsequent errors. The subsequent errors should tell you exactly which directories need permission to write (777).

I’m using godaddy, FYI.

Image Attachments
Picture 1.png
 
Magento Community Magento Community
Magento Community
Magento Community
 
michael_in_pp
Jr. Member
 
Total Posts:  11
Joined:  2008-05-27
 

I did the above, but found a handful of further changes were needed before the module would install:
- I had to make the permission changes outilned in this post: http://www.magentocommerce.com/boards/viewthread/47371/, although I didn’t have all the files listed there - this and the permission changes to the downloader folder outlined by lou enabled me to get past the INVALID POST error

- I then needed to make the following folders fully writeable (777):
.../app/code/community/
.../app/etc/modules/

Once those changes were complete the module installed OK.

It would be good practice to reset the folder and file permissions to 755.

I’m using Magento 1.3.0, on Centos running php as a module (DSO)

Many thanks to JoshMcGrath, lou and others for previous posts.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Tribsel
Jr. Member
 
Total Posts:  26
Joined:  2009-06-03
 

hi, I have the same problem. unfortuntelly nothing mentioned here does not work in my case…

 
Magento Community Magento Community
Magento Community
Magento Community
 
Clyde So
Jr. Member
 
Total Posts:  15
Joined:  2010-01-10
Australia
 

well… after setting everything (downloader and lib) to permission 777 (which is vulnerable btw), the downloader works.

if you guys are using ssh, recommend writing up a recursive script, otherwise, manually doing it like me

 
Magento Community Magento Community
Magento Community
Magento Community
 
shopjoni
Jr. Member
 
Total Posts:  1
Joined:  2009-09-28
 

I managed it by setting 777 for those files/folders additionaly:

/path/to/your/magento-install/downloader/pearlib/
/path/to/your/magento-install/downloader/pearlib/php/PEAR
/path/to/your/magento-install/downloader/pearlib/php/PEAR/Downloader
/path/to/your/magento-install/downloader/pearlib/php/PEAR/frontend
/path/to/your/magento-install/downloader/pearlib/php/PEAR/installer
/path/to/your/magento-/path/to/your/magento-install/downloader/pearlib/php/PEAR/install/downloader/pearlib/php/PEAR/config.php
/path/to/your/magento-install/downloader/pearlib/php/PEAR/installer.php
/path/to/your/magento-install/downloader/pearlib/php/PEAR/packageFileManager.php
/path/to/your/magento-install/downloader/pearlib/php/PEAR/packageFileManager2.php

 
Magento Community Magento Community
Magento Community
Magento Community
 
Metzed
Member
 
Total Posts:  32
Joined:  2010-08-11
 

Here’s a solution that fixed my problem. There was a specific rewrite rule in my htaccess file that I had added. I commented it out using a # at the beginning of the line and this fixed the ‘INVALID POST DATA’ error message. This is only likely to be a solution if you have added rewrite rules to your htaccess.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top