Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Upgrade from 1.5.1 to 1.7 Error
 
innerwolf
Member
 
Total Posts:  70
Joined:  2011-06-19
Leicester UK
 

Hi

I’ve just tried to upgrade to 1.7.0.2 and followed the instructions given here http://www.magentocommerce.com/wiki/1_-_installation_and_configuration/upgrading_magento#upgrading_magento_with_a_full_package_or_via_svn

But, I’m getting an error that looks to relate to rewriting a table on the sql.. This is the error I’m getting.

Error in file: “l/app/code/core/Mage/Catalog/sql/catalog_setup/upgrade-1.6.0.0.9-1.6.0.0.10.php” - SQLSTATE[HY000]: General error: 1005 Can’t create table ‘wildbird_magento.catalog_product_entity_group_price’ (errno: 150)

Trace:
#0 /home/wildbird/public_html/app/code/core/Mage/Core/Model/Resource/Setup.php(645): Mage::exception(’Mage_Core’, ‘Error in file: ...’)
#1 /home/wildbird/public_html/app/code/core/Mage/Core/Model/Resource/Setup.php(437): Mage_Core_Model_Resource_Setup->_modifyResourceDb(’upgrade’, ‘1.6.0.0.9’, ‘1.6.0.0.14’)
#2 /home/wildbird/public_html/app/code/core/Mage/Core/Model/Resource/Setup.php(320): Mage_Core_Model_Resource_Setup->_upgradeResourceDb(’1.6.0.0.9’, ‘1.6.0.0.14’)
#3 /home/wildbird/public_html/app/code/core/Mage/Core/Model/Resource/Setup.php(235): Mage_Core_Model_Resource_Setup->applyUpdates()
#4 /home/wildbird/public_html/app/code/core/Mage/Core/Model/App.php(417): Mage_Core_Model_Resource_Setup::applyAllUpdates()
#5 /home/wildbird/public_html/app/code/core/Mage/Core/Model/App.php(343): Mage_Core_Model_App->_initModules()
#6 /home/wildbird/public_html/app/Mage.php(683): Mage_Core_Model_App->run(Array)
#7 /home/wildbird/public_html/index.php(87): Mage::run(’’, ‘store’)
#8 {main}

 
Magento Community Magento Community
Magento Community
Magento Community
 
MagenX
Enthusiast
 
Total Posts:  791
Joined:  2008-05-26
Dublin
 

hi
while doing the upgrade you have to always delete the cache and refresh your browser
if the problem continues you have to dig in to this file

/app/code/core/Mage/Catalog/sql/catalog_setup/upgrade-1.6.0.0.9-1.6.0.0.10.php
and find the line number or table name
and compare it with your database.

here is some info on how to debug error 150
http://www.eliacom.com/mysql-gui-wp-errno-150.php

thank you

 
Magento Community Magento Community
Magento Community
Magento Community
 
joshuapchi
Jr. Member
 
Total Posts:  3
Joined:  2011-11-17
 

I found what fixed the problem for me. In MySQL I deleted the following databases, as they were empty anyway.

DROP TABLE catalog_product_entity_group_price;
DROP TABLE catalog_product_index_group_price;
 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top