Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Display Attribute on Product Grid
 
Insidedesign
Member
 
Avatar
Total Posts:  73
Joined:  2007-11-20
Asheville, NC
 

How would I go about pulling data from an attribute and displaying it in the product grid (under the title/link to it’s product page)? I am actually interested in displaying two product attributes. Thanks in advance!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Insidedesign
Member
 
Avatar
Total Posts:  73
Joined:  2007-11-20
Asheville, NC
 

Is there are certain query for this? Any direction is helpful…

 
Magento Community Magento Community
Magento Community
Magento Community
 
Insidedesign
Member
 
Avatar
Total Posts:  73
Joined:  2007-11-20
Asheville, NC
 

I found this: http://www.magentocommerce.com/wiki/how-to/add-attributes-to-product-grid
Unfortunately, I believe it to be outdated. Is it possible to get this updated?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Insidedesign
Member
 
Avatar
Total Posts:  73
Joined:  2007-11-20
Asheville, NC
 

Any update for this?

 
Magento Community Magento Community
Magento Community
Magento Community
 
capple_
Jr. Member
 
Total Posts:  17
Joined:  2008-04-02
 

Hi,

This link seems to have been useful for some: http://www.magentocommerce.com/boards/viewthread/1610/

However, I’ve followed the advices and made the necessary changes to catalog.xml and list.phtml (or view.phtml if you want the custom attributes to appear on product page) but can’t seem to get this code:

<?=$_product->getAttributeText('custom_attribute')?>
to display the custom attributes.

My temporary get around, is posted in this thread: http://www.magentocommerce.com/boards/viewthread/5374/

Hope this helps. And if you can get getAttributeText working for you, please do let me know how!

Thanks.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top