Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

integrate mailchimp simple subscribe into homepage
 
DDMAN
Sr. Member
 
Total Posts:  179
Joined:  2008-01-08
 

Afternoon everyone,

I have been stumped by this issue trying to integrate the mailchimp simple subscribe code into my magento website.

The code that I’m trying to integrate is found here http://www.mailchimp.com/api/downloads/#examples

So here’s what I’ve got.

I’m editing app/design/frontend/default/mytheme/templates/newsletter/subscribe.phtml

I tried adding the following code from the simple subscribe example from mailchimp which is

<p id="description">Get a Free Coupon Now.</p>
         <
form id="signup" action="<?=$_SERVER['PHP_SELF']; ?>" method="get">
          <
fieldset>
            <
legend>Join Our Newsletter</legend>
              
              <
label for="email" id="address-label">Email Address
                
<span id="response">
                    
<? require_once('inc/store-address.php'); if($_GET['submit'])echo storeAddress(); } ?>
                  
</span>
              </
label>
              <
input type="text" name="email" id="email" />
              <
input type="image" src="i/join.jpg" name="submit" value="Join" class="btn" alt="Join" />
            
              <
div id="no-spam">We'll never spam or give this address away</div>
          </fieldset>
        </form>      
        <script type="text/javascript" src="js/prototype.js"></script>
        <script type="text/javascript" src="js/mailing-list.js"></script>
</div>

When I add this and upload it gives me a php error and php stops when it tries to require the inc/store-address.php

I’ve tried changing it to include_once rather then require_once and it simply throws an error and says ajax is not defined or URL file access is denied on the server.

I’ve looked at this post to see how to implement ajax calls http://www.magentocommerce.com/boards/viewthread/12736/ and couldn’t make heads or tails of the post.

Anyone have any thoughts?

 
Magento Community Magento Community
Magento Community
Magento Community
 
DDMAN
Sr. Member
 
Total Posts:  179
Joined:  2008-01-08
 

Anybody have any thoughts on this?

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top