Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Magento connect manager error
 
Brandammo
Jr. Member
 
Avatar
Total Posts:  18
Joined:  2009-06-04
Surrey, UK
 

Can anyone please help?

Installation went fine. I can access Magento Admin and everything works as expected but when trying to access the “Magento Connect Manager” or the “Package Extensions” link under “System” I get the following error…

There has been an error processing your request.

Warningsession_start() [function.session-start]Cannot send session cache limiter headers already sent (output started at /home/coresprt/public_html/magento/downloader/pearlib/php/System.php:474)  in /home/coresprt/public_html/magento/app/code/core/Mage/Core/Model/Session/Abstract/Varien.php on line 99
Trace
:
#0 /home/coresprt/public_html/magento/app/code/core/Mage/Core/Model/Session/Abstract/Varien.php(99): mageCoreErrorHandler(2, 'session_start()...', '/home/coresprt/...', 99, Array)
#1 /home/coresprt/public_html/magento/app/code/core/Mage/Core/Model/Session/Abstract/Varien.php(154): Mage_Core_Model_Session_Abstract_Varien->start()
#2 /home/coresprt/public_html/magento/app/code/core/Mage/Core/Model/Session/Abstract.php(83): Mage_Core_Model_Session_Abstract_Varien->init('adminhtml')
#3 /home/coresprt/public_html/magento/app/code/core/Mage/Core/Model/Session.php(39): Mage_Core_Model_Session_Abstract->init('core', 'adminhtml')
#4 /home/coresprt/public_html/magento/app/code/core/Mage/Core/Model/Config.php(1086): Mage_Core_Model_Session->__construct('core', 'adminhtml')
#5 /home/coresprt/public_html/magento/app/Mage.php(319): Mage_Core_Model_Config->getModelInstance(Array)
#6 /home/coresprt/public_html/magento/app/Mage.php(333): Mage::getModel('core/session', Array)
#7 /home/coresprt/public_html/magento/app/code/core/Mage/Core/Controller/Varien/Action.php(440): Mage::getSingleton('core/session', Array)
#8 /home/coresprt/public_html/magento/app/code/core/Mage/Adminhtml/Controller/Action.php(130): Mage_Core_Controller_Varien_Action->preDispatch('core/session', Array)
#9 /home/coresprt/public_html/magento/app/code/core/Mage/Core/Controller/Varien/Action.php(365): Mage_Adminhtml_Controller_Action->preDispatch()
#10 /home/coresprt/public_html/magento/app/code/core/Mage/Core/Controller/Varien/Router/Standard.php(248): Mage_Core_Controller_Varien_Action->dispatch()
#11 /home/coresprt/public_html/magento/app/code/core/Mage/Core/Controller/Varien/Front.php(158): Mage_Core_Controller_Varien_Router_Standard->match('index')
#12 /home/coresprt/public_html/magento/app/Mage.php(459): Mage_Core_Controller_Varien_Front->dispatch(Object(Mage_Core_Controller_Request_Http))
#13 /home/coresprt/public_html/magento/index.php(65): Mage::run()
#14 {main}

Thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
stefetrucki
Jr. Member
 
Total Posts:  4
Joined:  2009-01-18
 

hi

I get also an error
and I think my provider blocks it:

Exception caught:

Warningpopen() has been disabled for security reasons in /home/trucki/public_html/magento/downloader/pearlib/php/OS/Guess.php on line 247

Backtrace
:

#0 /home/trucki/public_html/magento/downloader/pearlib/php/OS/Guess.php(247): mageCoreErrorHandler(2, 'popen() has bee...', '/home/trucki/pu...', 247, Array)
#1 /home/trucki/public_html/magento/downloader/pearlib/php/OS/Guess.php(159): OS_Guess->_detectGlibcVersion('/usr/bin/cpp /t...', 'r')
#2 /home/trucki/public_html/magento/downloader/pearlib/php/OS/Guess.php(114): OS_Guess->parseSignature()
#3 /home/trucki/public_html/magento/downloader/pearlib/php/PEAR/Dependency2.php(105): OS_Guess->OS_Guess(NULL)
#4 /home/trucki/public_html/magento/downloader/pearlib/php/PEAR/Downloader.php(259): PEAR_Dependency2->PEAR_Dependency2()
#5 /home/trucki/public_html/magento/downloader/pearlib/php/PEAR/Downloader.php(501): PEAR_Downloader->getDependency2Object(Object(PEAR_Config), Array, Array, 4)
#6 /home/trucki/public_html/magento/downloader/pearlib/php/PEAR/Downloader.php(409): PEAR_Downloader->analyzeDependencies(Object(PEAR_Config), Array, Array, 4)
#7 /home/trucki/public_html/magento/downloader/pearlib/php/PEAR/Command/Install.php(629): PEAR_Downloader->download(Array)
#8 /home/trucki/public_html/magento/downloader/pearlib/php/PEAR/Command/Common.php(285): PEAR_Command_Install->doInstall(Array)
#9 /home/trucki/public_html/magento/downloader/Maged/Pear.php(234): PEAR_Command_Common->run('install', Array, Array)
#10 /home/trucki/public_html/magento/downloader/Maged/Pear.php(301): Maged_Pear->run('install', Array, Array)
#11 /home/trucki/public_html/magento/downloader/Maged/Model/Pear.php(245): Maged_Pear->runHtmlConsole('install', Array, Array)
#12 /home/trucki/public_html/magento/downloader/Maged/Controller.php(128): Maged_Model_Pear->installPackage(Array)
#13 /home/trucki/public_html/magento/downloader/Maged/Controller.php(355): Maged_Controller->pearInstallPackagePostAction('magento-communi...')
#14 /home/trucki/public_html/magento/downloader/Maged/Controller.php(170): Maged_Controller->dispatch()
#15 /home/trucki/public_html/magento/downloader/index.php(35): Maged_Controller::run()
#16 {main}

If anyone can help we would be pleaset

thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
losse
Member
 
Total Posts:  69
Joined:  2009-01-31
 

I’m getting the same error too (bumping this up)

 
Magento Community Magento Community
Magento Community
Magento Community
 
brsacjab
Jr. Member
 
Total Posts:  6
Joined:  2009-07-26
 

Same issue, but when I tried today, get a blank screen when trying to access Magento Connect Manager or package extensions in Mozilla, 500 internal server error response in IE8.

Seems like I have something not set or mis-configured ???

file permissions ?

1.3.2.3 version, php 5.2

You guys have any luck with your errors?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Cesar Vasquez
Jr. Member
 
Total Posts:  18
Joined:  2009-09-19
 
stefetrucki - 13 June 2009 04:53 PM

hi

I get also an error
and I think my provider blocks it:

Exception caught:

Warningpopen() has been disabled for security reasons in /home/trucki/public_html/magento/downloader/pearlib/php/OS/Guess.php on line 247

Backtrace
:

#0 /home/trucki/public_html/magento/downloader/pearlib/php/OS/Guess.php(247): mageCoreErrorHandler(2, 'popen() has bee...', '/home/trucki/pu...', 247, Array)
#1 /home/trucki/public_html/magento/downloader/pearlib/php/OS/Guess.php(159): OS_Guess->_detectGlibcVersion('/usr/bin/cpp /t...', 'r')
#2 /home/trucki/public_html/magento/downloader/pearlib/php/OS/Guess.php(114): OS_Guess->parseSignature()
#3 /home/trucki/public_html/magento/downloader/pearlib/php/PEAR/Dependency2.php(105): OS_Guess->OS_Guess(NULL)
#4 /home/trucki/public_html/magento/downloader/pearlib/php/PEAR/Downloader.php(259): PEAR_Dependency2->PEAR_Dependency2()
#5 /home/trucki/public_html/magento/downloader/pearlib/php/PEAR/Downloader.php(501): PEAR_Downloader->getDependency2Object(Object(PEAR_Config), Array, Array, 4)
#6 /home/trucki/public_html/magento/downloader/pearlib/php/PEAR/Downloader.php(409): PEAR_Downloader->analyzeDependencies(Object(PEAR_Config), Array, Array, 4)
#7 /home/trucki/public_html/magento/downloader/pearlib/php/PEAR/Command/Install.php(629): PEAR_Downloader->download(Array)
#8 /home/trucki/public_html/magento/downloader/pearlib/php/PEAR/Command/Common.php(285): PEAR_Command_Install->doInstall(Array)
#9 /home/trucki/public_html/magento/downloader/Maged/Pear.php(234): PEAR_Command_Common->run('install', Array, Array)
#10 /home/trucki/public_html/magento/downloader/Maged/Pear.php(301): Maged_Pear->run('install', Array, Array)
#11 /home/trucki/public_html/magento/downloader/Maged/Model/Pear.php(245): Maged_Pear->runHtmlConsole('install', Array, Array)
#12 /home/trucki/public_html/magento/downloader/Maged/Controller.php(128): Maged_Model_Pear->installPackage(Array)
#13 /home/trucki/public_html/magento/downloader/Maged/Controller.php(355): Maged_Controller->pearInstallPackagePostAction('magento-communi...')
#14 /home/trucki/public_html/magento/downloader/Maged/Controller.php(170): Maged_Controller->dispatch()
#15 /home/trucki/public_html/magento/downloader/index.php(35): Maged_Controller::run()
#16 {main}

If anyone can help we would be pleaset

thanks

I Get the same Error :S

do you have some solution??

 
Magento Community Magento Community
Magento Community
Magento Community
 
princyjoy
Jr. Member
 
Total Posts:  2
Joined:  2009-09-11
 

Hi ,
On installing the IDEAL payment gateway using magento connecter i am getting the same warning of
popen() disabled for security reasons .
My hosting provider is not ready to enable it and they are telling to try another way with CURL .
Can anyone help me please ??

 
Magento Community Magento Community
Magento Community
Magento Community
 
dlbunker
Jr. Member
 
Total Posts:  4
Joined:  2009-10-08
 

I’m getting the same errors as everyone else has described. Anyone have any ideas?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Kenneth Peter Nielsen
Jr. Member
 
Total Posts:  1
Joined:  2007-11-05
 

A solution to this is to change line 474 of the file System.php in this directory:
/downloader/pearlib/php/System.php

Change:
return realpath(?/tmp?);
to:
return realpath(?../tmp?);

That solved the problem for us.

/Kenneth

 
Magento Community Magento Community
Magento Community
Magento Community
 
winta
Member
 
Total Posts:  38
Joined:  2009-09-28
 

I have changed the lines in the file / var/ www/ vhosts/ your_domain conf/ httpd.include
searched for the lines php_admin_flag engine on and changes them to php_admin_flag engine off
restarted apache
this worked for me

also change in the php.ini file sage mode off

 
Magento Community Magento Community
Magento Community
Magento Community
 
JLHC
Mentor
 
Avatar
Total Posts:  1287
Joined:  2008-05-09
Tampa, FL
 

For the following error:-

Warning: popen() has been disabled for security reasons

This means that your hosting provider has “popen” disabled in their server, which prevents you from using the Magento Connect Manager.
What I can suggest you to do is to contact your hosting provider to check whether they are able to enable this feature for you.

 
Magento Community Magento Community
Magento Community
Magento Community
 
amre3l
Jr. Member
 
Total Posts:  4
Joined:  2009-11-04
 
Kenneth Peter Nielsen - 15 October 2009 11:45 PM

A solution to this is to change line 474 of the file System.php in this directory:
/downloader/pearlib/php/System.php

Change:
return realpath(?/tmp?);
to:
return realpath(?../tmp?);

That solved the problem for us.

/Kenneth

Well, that’s solve my problem, thanks,

 
Magento Community Magento Community
Magento Community
Magento Community
 
WebhostUK LTD
Sr. Member
 
Avatar
Total Posts:  163
Joined:  2009-08-27
UK
 

Hello,

Thank you for the solution..solved a issue related to one of our clients website.

 
Magento Community Magento Community
Magento Community
Magento Community
 
relentless1
Member
 
Total Posts:  67
Joined:  2009-04-02
 

solution posted here

http://www.magentocommerce.com/boards/viewthread/179097/

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top