Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

I’m getting this error on installation
 
shamblix
Jr. Member
 
Total Posts:  6
Joined:  2008-03-15
 

Hi everyone, im really excited about using magento. So far it looks like the best thing out there, and i’ve seen pretty much everything.
Here’s my problem. Im hosting with 1and1. They run both PHP4 and PHP5 but not PHP5.2, so i have to use the work around. I’ve uploaded my entire directory to my server. I placed my cgi-bin directory inside. I have edited the permissions to 755 for both the folder and cgi file.

When I try to start the installation, i get this error message. What am I doing wrong? I think that my cgi-bin directory is in the right place otherwise I wouldn’t get this message.

WarningUnexpected character in input'' (ASCII=15state=1 in /homepages/3/d107836756/htdocs/SHEZABELS/cgi-bin/php5-cgi on line 130

Warning
Unexpected character in input' in /homepages/3/d107836756/htdocs/SHEZABELS/cgi-bin/php5-cgi on line 130

Warning: Unexpected character in input: ' 
in /homepages/3/d107836756/htdocs/SHEZABELS/cgi-bin/php5-cgi on line 130

Warning
Unexpected character in input' in /homepages/3/d107836756/htdocs/SHEZABELS/cgi-bin/php5-cgi on line 130

Parse error: syntax error, unexpected T_STRING in /homepages/3/d107836756/htdocs/SHEZABELS/cgi-bin/php5-cgi on line 130

This is what my .htaccess file looks like.

############################################
## uncomment these lines for CGI mode
## make sure to specify the correct cgi php binary file name
## it might be /cgi-bin/php5-cgi

#Action php5-cgi /cgi-bin/php5-cgi
#AddHandler php5-cgi .php

############################################
## this line is specific for 1and1 hosting

#AddType x-mapp-php5 .php

############################################
## default index file

Action php5-cgi /cgi-bin/php5-cgi 
AddHandler php5
-cgi .php

DirectoryIndex index
.php

<IfModule mod_php5.c>

############################################
## adjust memory limit

    
php_value memory_limit 32M
    php_value max_execution_time 18000

############################################
## disable magic quotes for php request vars

    
php_flag magic_quotes_gpc off

############################################
## enable php short tags for templates

    
php_flag short_open_tag on

</IfModule>

<
IfModule mod_ssl.c>

############################################
## make HTTPS env vars available for CGI mode

    
SSLOptions StdEnvVars

</IfModule>

<
IfModule mod_rewrite.c>

############################################
## enable rewrites

    
Options +FollowSymLinks
    RewriteEngine on

############################################
## you can put here your magento root folder path relative to web root

    #RewriteBase /magento/

############################################
## workaround for HTTP authorization in CGI environment

    
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

############################################
## always send 404 on missing files in these folders

    
RewriteCond %{REQUEST_URI} !^/(media|skin|js)/

############################################
## never rewrite for existing files, directories and links

    
RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond 
%{REQUEST_FILENAME} !-d
    RewriteCond 
%{REQUEST_FILENAME} !-l

############################################
## rewrite everything else to index.php

    
RewriteRule .* index.php [L]

</IfModule>


############################################
## Prevent character encoding issues from server overrides
## If you still have problems, use the second line instead

AddDefaultCharset Off
#AddDefaultCharset UTF-8
Order allow,deny
Allow from all

any help is greatly appreciated. I hope I will be able to use Magento

 
Magento Community Magento Community
Magento Community
Magento Community
 
shamblix
Jr. Member
 
Total Posts:  6
Joined:  2008-03-15
 

Oh wow i just fixed it. I hope i will be able to go through the installation now.
I figure it good for other people so I will just state what I changed. I found this information in this thread.
http://www.magentocommerce.com/boards/viewthread/2019/P15/

basically, in my .htaccess file, instead of just adding

Action php5-cgi /cgi-bin/php5-cgi 
AddHandler php5
-cgi .php
I added
Action php5-cgi /cgi-bin/php5-cgi 
AddHandler php5
-cgi .php
AddHandler x
-mapp-php .php4
AddHandler x
-mapp-php5 .php
and it worked. Nice!
 
Magento Community Magento Community
Magento Community
Magento Community
 
shamblix
Jr. Member
 
Total Posts:  6
Joined:  2008-03-15
 

What is this?? I was at the part where I was entering the database information. I clicked next and I got this. Now it wont go away even if I try to do installation again. Help
Take a look at this wierd stuff

 
Magento Community Magento Community
Magento Community
Magento Community
 
bonbon
Jr. Member
 
Total Posts:  1
Joined:  2009-02-23
 

thanks shamblix that helped me

 
Magento Community Magento Community
Magento Community
Magento Community
 
pmchardy
Jr. Member
 
Total Posts:  3
Joined:  2009-05-10
 

your reply Helped me too,

many thanks

Peter

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top