Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Error getIdFieldName() on the product page
 
wowtilla
Jr. Member
 
Avatar
Total Posts:  2
Joined:  2012-09-25
 

Hello friends, I am new to Magento, I am finalizing my first shop, everything was going well, but when trying to add an attribute (color) to the product, there was an error that I could not identify. When trying to reverse the action in the frontend I get the following message below:

Fatal error: Call to a member function getIdFieldName() on a non-object in /home/minhaloja/www/app/code/core/Mage/Core/Model/Abstract.php on line 151

And on the backend when I try to edit a product, comes the following message with a sequence of 52 errors:

There has been an error processing your request
Mage registry key “_resource_singleton/customer/group” already exists

Trace:
#0 /home/minhaloja/www/app/Mage.php(222): Mage::throwException(’Mage registry k...’)
#1 /home/minhaloja/www/app/Mage.php(518): Mage::register(’_resource_singl...’, false)
...
#51 /home/minhaloja/www/index.php(87): Mage::run(’’, ‘store’)
#52 {main}

Error log record number: 368046764929

Can anyone help me? I spent an entire afternoon looking for but not found, and this was my last resort ...

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top