Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Checkout button not working after I upgraded from 1.6 to 1.7. - Am I missing something? 
 
jcastellon
Jr. Member
 
Avatar
Total Posts:  5
Joined:  2013-07-01
 

The store works when I add an item, but when I click to checkout the link re-directs to the home page store. It’s the same when I click on Proceed to checkout. Before, I had the cache management disabled and now is enabled. Is this related or what could be causing this problem? Thanks so much for the help, with kind regards.

 
Magento Community Magento Community
Magento Community
Magento Community
 
GoMageTeam
Guru
 
Avatar
Total Posts:  356
Joined:  2013-01-13
Warsaw, Poland
 

Hello,

Please, provide us with the link to your site.

 
Magento Community Magento Community
Magento Community
Magento Community
 
jcastellon
Jr. Member
 
Avatar
Total Posts:  5
Joined:  2013-07-01
 

I fixed and these where the steps I took to make it work. However, before you do any of the following work disable your cache management:

1. Open Magento admin panel
2. Go to System>Cache Management
3. Check all Cache types and in the Actions box select refresh
4. Then select all Cache types and in the Actions box select disable
5. Also click Flush Magento Cache and Flush Cache Storage buttons
Now you are free to perform any changes to your store.

Now, if you upgraded and nothing works make sure that under:

System/Configuration -> Web – Default Pages /that your ‘Home page’ is listed under
‘CMS Home Page’.  Also check:
System/Configuration -> Design – Packages /that your ‘Template’ is listed under
‘Current Package Name’. Otherwise default takes over.

Note: your template will still come up with all its features and buttons in your browser, even if no home page is setup; this is because of the previous version configuration.

If the ‘Home Page’ and ‘Template’ are not listed, add them and go into your File System and erase everything under ‘var/cache’ and ‘var/session’.  Reload your home page: www.yourstore.com/magento/ it should work. After, all work is done enable your cache management.

Also, it’s good to check that your home page lands at the store, and to check - do the following:

1.  Login to your Magento MySQL database.
2.  Open the table [database_prefix]
3.  Locate core_config_data.
4.  Find the row with entry:  ‘web/unsecure/base_url’ and ‘web/secure/base_url’ they should look like www.yourstore.com/magento/ or whatever you name your magento store file.

I hope this help someone, it took a lot to make it work!

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top