Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 1 of 2
Backend login after installation not possible - always redirected to the login-page
 
shd-media
Jr. Member
 
Avatar
Total Posts:  21
Joined:  2008-03-15
 

Hello,

today i startet install Magento local under xampp. after the installation i wanted to login to the backend. But even if I enter my username and my password, the system redirects me to the backend-login page. There is no error massage or anything else. It might be a problem with the xampp configuration?

Have had anyone else a sminilar problem? I don?t know how to fix it.

best regards

 
Magento Community Magento Community
Magento Community
Magento Community
 
renjith
Jr. Member
 
Total Posts:  1
Joined:  2008-03-15
 

Hi There,
Am also experiencing the same issue. Installation is on a windows2000 server with wamp 2.0. Could anyone please help to fix this issue?

Note: mod_rewrite is enabled

Regards
Renjith

 
Magento Community Magento Community
Magento Community
Magento Community
 
prancer
Jr. Member
 
Total Posts:  4
Joined:  2008-03-13
 

Have the same problem

Specs:
XAMPP 1.6.6a
Windows XP

I also followed this wiki: http://www.magentocommerce.com/wiki/general/installing_on_windows_with_xampp_and_wamp

 
Magento Community Magento Community
Magento Community
Magento Community
 
HoKiDoc
Jr. Member
 
Avatar
Total Posts:  4
Joined:  2008-02-16
 

use url http://127.0.0.1 instead of http://localhost or change your hosts files smile
there’s some backend ip restriction wink

 
Magento Community Magento Community
Magento Community
Magento Community
 
shd-media
Jr. Member
 
Avatar
Total Posts:  21
Joined:  2008-03-15
 

Hey, thank you very much. Now with ip it works great.

 
Magento Community Magento Community
Magento Community
Magento Community
 
bigodines
Jr. Member
 
Avatar
Total Posts:  27
Joined:  2008-01-05
Brazil
 

i would suggest magento crew to add this information to the main website as most users are unable to login in the backend and it is quite frustrating smile

I thought it was something wrong with the sample data… o_O :D

 
Magento Community Magento Community
Magento Community
Magento Community
 
Moshe
Magento Team
 
Avatar
Total Posts:  1770
Joined:  2007-08-07
Los Angeles
 

Actually this is not a backend restriction, this should affect frontend too (not able to login as customer) since this is a know limitation of browsers, which do not store cookies for domains without dot.

 
Magento Community Magento Community
Magento Community
Magento Community
 
pm4872
Sr. Member
 
Total Posts:  76
Joined:  2007-11-06
France
 

Hello,
Same problem with OS X (10.4)
What should i do ?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Lior
Magento Team
 
Avatar
Total Posts:  293
Joined:  2007-09-24
 

did you try the same solution?
Try to use or the IP or change in the hosts file to be localhost.com

 
Magento Community Magento Community
Magento Community
Magento Community
 
pm4872
Sr. Member
 
Total Posts:  76
Joined:  2007-11-06
France
 

Nop ... I should but I don’t see what they mean by changing the host file !!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Lior
Magento Team
 
Avatar
Total Posts:  293
Joined:  2007-09-24
 

Try to use this http://127.0.0.1 instead of the http://localhost

Do modify your hosts file on MAC you should:
Open Finder and go to Applications, then to Utilities and open Terminal
type:
cd /etc
And press enter
then type: cat hostsAnd press enter
then type: sudo pico hosts
And press enter
You will be prompted for your computer admin password. Enter this (you will not see it as you type) and press enter.
This will open the host file in the edit mode
Use the arrow key to go down with the cursor and add the ip address
[PUT IP ADDRESS AND DOMAIN NAME HERE] (in your case 127.0.0.1 localhost.com)
Press control x to exit and press y to save the file. Here you may be prompted to press enter to save the file, or asked the file name to write (as you would in word, etc) just press enter to save as file name hosts.
You will then need to restart the computer to save the changes.
If you want to see the old site follow the instructions above and once you have the file open use your mouse cursor to go down to the ip address. Add # in front of the ip, so the line will now look like
# [PUT IP ADDRESS AND DOMAIN NAME HERE]
Save the file the same way, reboot and you will be able to view the old site.

 
Magento Community Magento Community
Magento Community
Magento Community
 
pm4872
Sr. Member
 
Total Posts:  76
Joined:  2007-11-06
France
 

Hello,
IP solution does not work, and ... Sorry but, I don’t want to use Terminal, I really don’t know anything about this !!
I sincerely think this problem has to be fixed by Magento.
Earlier versions used to work well ... so ????

 
Magento Community Magento Community
Magento Community
Magento Community
 
Juxecl
Member
 
Total Posts:  37
Joined:  2007-12-08
 

On Mac OS X 10.4 you can also use the computer name + .local as the url.

If you go to System Preferences->Sharing you can view/edit the computer name.

Then access your local server with:

http://computer_name.local/path/to/magento/

Change computer_name to the real one and the path to the actual Magento installation too of course smile

 
Magento Community Magento Community
Magento Community
Magento Community
 
bendosul
Jr. Member
 
Total Posts:  2
Joined:  2008-03-18
 

Mac OS 10.5 and Mamp 1.7.1
Try some of your solutions...no way
I stay on the Backend login page...with right username and password.
Boring and frustating.

 
Magento Community Magento Community
Magento Community
Magento Community
 
madmax74
Jr. Member
 
Total Posts:  1
Joined:  2008-03-18
 

x bendosul

Try to access the admin page with http://127.0.0.1:8888/admin

 
Magento Community Magento Community
Magento Community
Magento Community
 
pm4872
Sr. Member
 
Total Posts:  76
Joined:  2007-11-06
France
 

... euh !!! All my excuses, it works well with :
http://127.0.0.1:8888/magento/admin
(I was forgetting the “:8888") !!!
Thanks every one.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 1 of 2