Magento Forum

   
Mage 1.8a SOAP API issues
 
idamav
Jr. Member
 
Total Posts:  6
Joined:  2011-03-01
 

Hi all,

While the same API client works fine for 1.7.0.2, it doesn’t work at all with 1.8a,
I keep getting on the login request the following response:
<?xml version="1.0" encoding="UTF-8"?>
<SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/">
<SOAP-ENV:Body>
<SOAP-ENV:Fault>
<faultcode>2</faultcode>
<faultstring>Access denied.</faultstring>
</SOAP-ENV:Fault>
</SOAP-ENV:Body>
</SOAP-ENV:Envelope>

While all the web service config (user and API) key are defined.
Anyone else facing this issue? I know it’s a alpha release but would be great to know if the SOAP API is working at all in this version.

thanks!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Zuru
Jr. Member
 
Avatar
Total Posts:  4
Joined:  2013-05-20
 

I’m facing the same issue. It’s impossible to access to the API. Anyone knows how to fix this?

 
Magento Community Magento Community
Magento Community
Magento Community
 
idamav
Jr. Member
 
Total Posts:  6
Joined:  2011-03-01
 

I tried ...everything to make this work. However, I’m a newbie on the API V2 SOAP part. I tried setting and removing WSI, created new users and roles etc etc but still getting ‘Access denied’ back when trying to login on the web service.

Any ideas?

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
    Back to top