Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 1 of 2
Addresses not saved
 
sawdust
Jr. Member
 
Total Posts:  28
Joined:  2009-03-18
 

Am going through the testing process of creating a new account.  Account creation works fine.  After logging in, I try to create a new address under Manage Addresses and the address is never saved after a submit.

I’ve double checked from the admin interface for that customer, but the address I submitted is not there.

It doesn’t work whether or not I use security (HTTPS) on the frontend or not.

I don’t see any errors in the Magento error logs or Apache’s error logs.  I don’t see any user interface errors.  After the submit, the blank form (except for the name that was saved when the account was created), is shown.

Any ideas for where to start to debug and track that down?

 
Magento Community Magento Community
Magento Community
Magento Community
 
sawdust
Jr. Member
 
Total Posts:  28
Joined:  2009-03-18
 

should have mentioned that I’m running Magento 1.3.1

 
Magento Community Magento Community
Magento Community
Magento Community
 
sawdust
Jr. Member
 
Total Posts:  28
Joined:  2009-03-18
 

I threw some system log messages into the file:  app/code/core/Mage/Customer/controllers/AddressControllers.php in the formPostAction method.

The first code it calls is:

if ( !$this->_validateFormKey() )

This condition is true and immediately redirects to another new form via a return....it never gets as far as processing any of the post.

The _validateFormKey() code is in:
code/core/Mage/Core/Controller/Varien/Action.php but I don’t really understand what it’s trying to accomplish without know a lot more about the internals of Magento.  It’s obviously returning false because the ! return value is true for the condition above to be true.

 
Magento Community Magento Community
Magento Community
Magento Community
 
sawdust
Jr. Member
 
Total Posts:  28
Joined:  2009-03-18
 

Just saw this thread http://www.magentocommerce.com/boards/viewthread/40013/ but it doesn’t really answer the question, it just gets around the problem by commenting out the _validateFormKey call. 

Anyone have any experience with the internals at this level who can explain what’s going on?

 
Magento Community Magento Community
Magento Community
Magento Community
 
tubadc
Sr. Member
 
Total Posts:  95
Joined:  2008-05-07
Floripa | BR
 

same problem, same version.... :(

 
Magento Community Magento Community
Magento Community
Magento Community
 
sawdust
Jr. Member
 
Total Posts:  28
Joined:  2009-03-18
 

I finally just commented out that little chunk of code and moved on.  It’s really disappointing to have absolutely no response from the developers on this type of problem.  I’ve invested so much time and effort into this platform that I feel trapped now because the support for it is so low.

 
Magento Community Magento Community
Magento Community
Magento Community
 
The Sunday Paper
Sr. Member
 
Total Posts:  202
Joined:  2008-08-06
 

I’m having the exact same problem as well. You may find (as I have) that for many of those customers that can’t save their addresses, the “change password” form is behaving the same way — confirming that the change has been made but saving nothing to the database. Would really like to know what’s up. What is the _validateFormKey call meant to do? Surely there’s some downside to commenting it out, but do you know what that is, by any chance, sawdust?

 
Magento Community Magento Community
Magento Community
Magento Community
 
xbytes
Jr. Member
 
Total Posts:  3
Joined:  2008-10-25
 

Hello, same problem here. Any solutions?

 
Magento Community Magento Community
Magento Community
Magento Community
 
gfxguru
Sr. Member
 
Total Posts:  186
Joined:  2008-11-20
 

I’m not liking the way the guys at Magento are starting to treat it’s users, developers, etc. I know the business plan has changed and support for issues that I believe should be FIXED BY NOW is not going to happen. Just hoped it wouldn’t come to this. IMHO It may be time to look into another solution, but that’s just me. There are quite a few other open source solutions out there.

 
Magento Community Magento Community
Magento Community
Magento Community
 
The Sunday Paper
Sr. Member
 
Total Posts:  202
Joined:  2008-08-06
 

I’m noticing now that (presumably due to this same problem) my system also won’t save tags that a user enters. It prompts the user to log in, then doesn’t respond to the entry of tags.

 
Magento Community Magento Community
Magento Community
Magento Community
 
sawdust
Jr. Member
 
Total Posts:  28
Joined:  2009-03-18
 

I put together a bug report attempting to describe this defect and filed it - the bug id is 14720

The URL is:

http://www.magentocommerce.com/bug-tracking/issue?issue=6626

If you’d like to describe it further based on the problems you’ve encountered

 
Magento Community Magento Community
Magento Community
Magento Community
 
The Sunday Paper
Sr. Member
 
Total Posts:  202
Joined:  2008-08-06
 

Cool. FYI, the saving of tags may indeed have been a separate problem, as I solved that by replacing the tag/list.phtml content in my Modern-based theme with the same file from the default theme. Those save now. Could the addresses and passwords problem be related to the Modern theme as well? Are all of you who are having this problem using Modern?

 
Magento Community Magento Community
Magento Community
Magento Community
 
sawdust
Jr. Member
 
Total Posts:  28
Joined:  2009-03-18
 

I’m using a Photoshop modified theme purchased from Template Monster, specifically:  http://www.templatemonster.com/magento-themes/21812.html

 
Magento Community Magento Community
Magento Community
Magento Community
 
Kara Heinrichs
Guru
 
Avatar
Total Posts:  482
Joined:  2008-01-17
aa, mi, us
 

I was worried when I saw this thread.  I just upgraded 2 our our Magento installations.  But when I test it it works fine.  I’m able to create new addresses and changed my password as well.  So it doesn’t appear to be a Magento-wide issue.  Do you have any other customer or account customizations in place that might conflict with this functionality.

 
Magento Community Magento Community
Magento Community
Magento Community
 
The Sunday Paper
Sr. Member
 
Total Posts:  202
Joined:  2008-08-06
 

Kara,

On my system, it doesn’t appear to affect every user, although I have yet to identify a browser- or OS-related pattern. With that in mind, I recommend testing on as many combinations as you can get your hands on.

 
Magento Community Magento Community
Magento Community
Magento Community
 
sawdust
Jr. Member
 
Total Posts:  28
Joined:  2009-03-18
 

anyone aware of 1.3.x obsoleting or breaking 1.2.x templates?  It’s as though they added the form validation key in 1.3.x but 1.2.x templates didn’t have any of it there.  Just guessing, but sort of acts that way.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 1 of 2