Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Store Email Addresses - I must be missing something very simple please help a newbie
 
dougclark
Jr. Member
 
Total Posts:  6
Joined:  2009-04-28
 

I have a successful installation and everything appears to work so far. I have been building a prduact database and have successfully completed a trial order. However, one problem I have is when slecting the option to Configure “Store Email Addresses” I am directed to the Demo Store with the message below… I am sure I am missing something very simple here but have searched the forum and wiki to no avail.  PLEASE HELP

Thanks, Doug

Warning: include(Mage/Adminhtml/Model/System/Config/Backend/Email/Sender.php) [function.include]: failed to open stream: No such file or directory in /var/www/vhosts/promisingtea.com/httpdocs/lib/Varien/Autoload.php on line 93
Trace:
#0 /var/www/vhosts/promisingtea.com/httpdocs/lib/Varien/Autoload.php(93): mageCoreErrorHandler(2, ‘include(Mage/Ad...’, ‘/var/www/vhosts...’, 93, Array)
#1 /var/www/vhosts/promisingtea.com/httpdocs/lib/Varien/Autoload.php(93): Varien_Autoload::autoload()
#2 [internal function]: Varien_Autoload->autoload(’Mage_Adminhtml_...’)
#3 [internal function]: spl_autoload_call(’Mage_Adminhtml_...’)
#4 /var/www/vhosts/promisingtea.com/httpdocs/app/code/core/Mage/Core/Model/Config.php(1084): class_exists(’Mage_Adminhtml_...’)
#5 /var/www/vhosts/promisingtea.com/httpdocs/app/Mage.php(319): Mage_Core_Model_Config->getModelInstance(’adminhtml/syste...’, Array)
#6 /var/www/vhosts/promisingtea.com/httpdocs/app/code/core/Mage/Adminhtml/Block/System/Config/Form.php(242): Mage::getModel(’adminhtml/syste...’)
#7 /var/www/vhosts/promisingtea.com/httpdocs/app/code/core/Mage/Adminhtml/Block/System/Config/Form.php(180): Mage_Adminhtml_Block_System_Config_Form->initFields(Object(Varien_Data_Form_Element_Fieldset), Object(Mage_Core_Model_Config_Element), Object(Mage_Core_Model_Config_Element))
#8 /var/www/vhosts/promisingtea.com/httpdocs/app/code/core/Mage/Adminhtml/Block/System/Config/Edit.php(91): Mage_Adminhtml_Block_System_Config_Form->initForm()
#9 /var/www/vhosts/promisingtea.com/httpdocs/app/code/core/Mage/Adminhtml/controllers/System/ConfigController.php(87): Mage_Adminhtml_Block_System_Config_Edit->initForm()
#10 /var/www/vhosts/promisingtea.com/httpdocs/app/code/core/Mage/Core/Controller/Varien/Action.php(376): Mage_Adminhtml_System_ConfigController->editAction()
#11 /var/www/vhosts/promisingtea.com/httpdocs/app/code/core/Mage/Core/Controller/Varien/Router/Standard.php(248): Mage_Core_Controller_Varien_Action->dispatch(’edit’)
#12 /var/www/vhosts/promisingtea.com/httpdocs/app/code/core/Mage/Core/Controller/Varien/Front.php(158): Mage_Core_Controller_Varien_Router_Standard->match(Object(Mage_Core_Controller_Request_Http))
#13 /var/www/vhosts/promisingtea.com/httpdocs/app/Mage.php(459): Mage_Core_Controller_Varien_Front->dispatch()
#14 /var/www/vhosts/promisingtea.com/httpdocs/index.php(52): Mage::run()
#15 {main}

-----------------------------

 
Magento Community Magento Community
Magento Community
Magento Community
 
NeilA
Moderator
 
Avatar
Total Posts:  1372
Joined:  2007-09-17
Blue Mountains, Oz
 

Haven’t seen that before, but the error suggests a path is wrong somewhere… Is it really only when you attempt to configure store emails that it happens?

 
Magento Community Magento Community
Magento Community
Magento Community
 
dougclark
Jr. Member
 
Total Posts:  6
Joined:  2009-04-28
 

Yes, Everything else appears to be working fine. It is only when I select the option from the configuration menu “Store Email Addresses” that I get this message.
Could it be related to a permissions problem?
Thanks for your prompt reply.
Doug - Tea Drinker smile

 
Magento Community Magento Community
Magento Community
Magento Community
 
robin2160
Mentor
 
Avatar
Total Posts:  1046
Joined:  2009-02-15
Berlin / Germany
 

Now a think your Sender.php is broken or missing.
Upload this file agin from your backup (local)

The folder is:
app\code\core\Mage\Adminhtml\Model\System\Config\Backend\Email

Hope this helps

 
Magento Community Magento Community
Magento Community
Magento Community
 
dougclark
Jr. Member
 
Total Posts:  6
Joined:  2009-04-28
 

You are right. sender.php is missing. In fact the Email directory is missing from app\code\core\Mage\Adminhtml\Model\System\Config\Backend\Email.

This is a virgin installation.  I have two independent installations on different domains each has the same problem. The Email directory is missing in both cases.

It sounds like my problem is associated with the installation.  I installed from the command line using PuTTY.

Any help appreciated.

Many thanks.
Doug

 
Magento Community Magento Community
Magento Community
Magento Community
 
robin2160
Mentor
 
Avatar
Total Posts:  1046
Joined:  2009-02-15
Berlin / Germany
 

Now you can doing following:
1. Backup!
2. Download your version from the magento page (the full package)
3. Upload the hole app\code\core\Mage\Adminhtml dicetory via ftp (or putty if you like this)

no guarantee - make before a backup !

 
Magento Community Magento Community
Magento Community
Magento Community
 
dougclark
Jr. Member
 
Total Posts:  6
Joined:  2009-04-28
 

Success… This solved my problem.  many thanks.
As I did not understand what caused the problem I have also completed a new installation from scratch to ensure any other related problems do not occur. This worked also - I have done this as I need to be assured of a robust and secure application.

Thanks again - I have much confidence in Magento and the TEAM.

Regards till next time

Doug

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top