Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Problem when trying to preview transaction e-mail
 
zapp
Jr. Member
 
Total Posts:  19
Joined:  2009-03-27
 

Hello everybody,

since to days I’m getting this strange error when trying to preview transaction E-Mails. This only affects new order / new bill where products are listed:

Fatal errorCall to a member function getAllItems() on a non-object in /home/ilgshop/public_html/magento/app/design/adminhtml/default/default/template/email/order/items.phtml on line 38

The preview worked flawlessly until 2 days ago. I changed nothing, wether the magento installation nor the code for the Mails.

Thank you for your help.

 
Magento Community Magento Community
Magento Community
Magento Community
 
ConvenientGadgets
Sr. Member
 
Total Posts:  78
Joined:  2008-12-29
 

I am having the same problem. Don’t know where to start. Some emails work fine but not order for preview.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Brady
Guru
 
Avatar
Total Posts:  330
Joined:  2007-09-10
Orange County, CA
 

I’m receiving this error as well. We’re running a multi-store setup, so I don’t know if that has anything to do with it. Oddly, this error ONLY shows up on our hosted site. When I run the site locally using MAMP, there is no error and it previews as it should. Makes me think it may be a permissions issue.

 
Magento Community Magento Community
Magento Community
Magento Community
 
DaveDurlan
Jr. Member
 
Total Posts:  23
Joined:  2008-11-10
 

I’m getting the error for new order template only.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Soro
Jr. Member
 
Total Posts:  16
Joined:  2009-07-22
 

I am getting the same thign

 
Magento Community Magento Community
Magento Community
Magento Community
 
izzet
Member
 
Total Posts:  74
Joined:  2009-03-26
 
Soro - 02 August 2009 04:18 AM

I am getting the same thign

me too :((.. why this error

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top