Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Can anyone figure this out for me? PHP 4 Workaround Error. 
 
customcable
Jr. Member
 
Total Posts:  22
Joined:  2008-01-23
 

I’m having to use the PHP 4 workaround.  At first, I started to get 404 errors, then I got 500 errors.  Then I got the error that read “You need to use the PHP 4 workaround” from Magento.

Now, I’m on this error.  I feel like I’m so close.  I’m dying to check out this software and learn it.

Here’s the only thing that comes up:

Warning: Unexpected character in input: ‘’ (ASCII=15) state=1 in /nfs/cust/1/24/39/393421/cgi-bin/php5-cgi on line 131

Warning: Unexpected character in input: ‘ in /nfs/cust/1/24/39/393421/cgi-bin/php5-cgi on line 131

Warning: Unexpected character in input: ‘ in /nfs/cust/1/24/39/393421/cgi-bin/php5-cgi on line 131

Warning: Unexpected character in input: ‘ in /nfs/cust/1/24/39/393421/cgi-bin/php5-cgi on line 131

Parse error: syntax error, unexpected T_STRING in /nfs/cust/1/24/39/393421/cgi-bin/php5-cgi on line 131


Can I edit this file?  I’m not sure what the code is supposed to look like but mine has crazy symbols.

Any help would be appreciated.

Saxon

 
Magento Community Magento Community
Magento Community
Magento Community
 
GizzmoAsus
Jr. Member
 
Avatar
Total Posts:  17
Joined:  2008-02-21
Blackburn, UK
 

Try redownloading the php5-cgi and upload it to the server. Sounds like that file is corrupt :S

 
Magento Community Magento Community
Magento Community
Magento Community
 
customcable
Jr. Member
 
Total Posts:  22
Joined:  2008-01-23
 

Yep, tried that.  I’m downloading the one that Magento offers in their workaround.  And I’m uploading to my FTP in binary only.

Saxon

 
Magento Community Magento Community
Magento Community
Magento Community
 
customcable
Jr. Member
 
Total Posts:  22
Joined:  2008-01-23
 

I still can’t get this to work.  Anyone want to look at my php-info or htaccess files and see what is going on for me?

Saxon

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top