Magento Forum

For anybody installing on a Mosso server
 
davedavedave
Sr. Member
 
Avatar
Total Posts:  238
Joined:  2007-08-31
 

I just got the page to go from a 500 internal server error, to the install config (hopefully no issues when I install)....but for anybody on a Mosso server, you’ll need to update your main .htaccess file and add this line:

RewriteBase /

Once that is added, it went right to install.

Update: The install went perfectly (make sure to chmod to 777, not 755 for the appropriate directories).  Finally I can play around with Magento this week!  I wish I could get it working locally though, but better than nothing!

 
Magento Community Magento Community
Magento Community
Magento Community
 
imageNation
Jr. Member
 
Total Posts:  2
Joined:  2007-09-19
 

Hi thanks for this, I am trying to install on Mosso but the Magento installation package I downloaded doesn’t have a .htaccess file in the root of the installation.  Any chance you can copy and paste the one you have got working with Mosso.

Thanks for your help.

 
Magento Community Magento Community
Magento Community
Magento Community
 
imageNation
Jr. Member
 
Total Posts:  2
Joined:  2007-09-19
 

I do have the installation screen up now!  I found the following in the knowledge base

RewriteEngine on
RewriteCond $1 !^(index\.php|media|skin|js|robots\.txt)
RewriteRule ^(.*)$ /magento/index.php/$1 [L]

and added in your RewriteBase / tip and the installation screen is up!

Thanks that was bugging me

 
Magento Community Magento Community
Magento Community
Magento Community
 
kelbyuk
Jr. Member
 
Total Posts:  13
Joined:  2007-11-30
 

I have installed magento on my mosso account, added a couple of test products but cant see how to get them displayed. Anyone know where I might be going wrong?

 
Magento Community Magento Community
Magento Community
Magento Community
 
ashanholt
Member
 
Avatar
Total Posts:  33
Joined:  2007-09-05
 

Setting preferred state to: beta

config-set succeeded
Downloading 
and installing Magentoplease wait...

Attempting to discover channel "pear"...
unknown channel "pear" in "pear/PEAR-stable"
invalid package name/package file "pear/PEAR-stable"
Cannot initialize 'pear/PEAR-stable'invalid or missing package file
Attempting to discover channel 
"connect.magentocommerce.com/core"...
downloading channel.xml ...
Starting to download channel.xml (687 bytes)
....
done687 bytes
Auto
-discovered channel "connect.magentocommerce.com/core"alias "connect.magentocommerce.com/core"adding to registry
unknown channel 
"connect.magentocommerce.com/core" in "connect.magentocommerce.com/core/Mage_Pear_Helpers"
invalid package name/package file "connect.magentocommerce.com/core/Mage_Pear_Helpers"
Cannot initialize 'connect.magentocommerce.com/core/Mage_Pear_Helpers'invalid or missing package file

... and then later on in the script, an array dump and final error ...

[7] => Array
                (
                    
[0] => Package "connect.magentocommerce.com/core/Interface_Install_Default" is not valid
                
)

        )

    
[headline] => Install Errors
)

PEAR ERRORinstall failed

Regrettably, I’m stumped at this point. I’m not sure if the PEAR server is down, if Mosso can’t do this, or what. There’s no ability to drop to a command line on Mosso, and try to do it by hand, so I’m going to try again in a little bit… but if anyone has any ideas, it would be greatly appreciated!

EDIT: Note that this is discussed also in another forum, and apparently not unique to Mosso. Still not solved.

http://www.magentocommerce.com/boards/viewthread/2470/

 
Magento Community Magento Community
Magento Community
Magento Community
 
kelbyuk
Jr. Member
 
Total Posts:  13
Joined:  2007-11-30
 

I am also not able to install the new version of Magento onto my Mosso hosting. So any solutions smile
Also using the previous version, does anyone have an issue with uploading more than a couple of lines as an import?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Sprout Collective
Member
 
Total Posts:  64
Joined:  2007-08-31
Portland, OR / Orange County, CA
 

Are you still experiencing problems hosting Magento on Mosso?

I’m getting incredibly great performance out of Slicehost, using Litespeed to serve the app.  I was thinking of utilizing Mosso for stores that may not require such a custom hosting solution.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top