Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 2 of 2
Constat de lenteur
 
thierry_montpellier
Jr. Member
 
Total Posts:  4
Joined:  2008-07-03
 

Bonjour,

MmaxX, tu conseils d’installer APC !

J’aimerai savoir si suite a cette installation tu dois faire des modifications particulières dans MAGENTO ou si APC s’intègre automatiquement ?

D’avance merci de ta réponse

Thierry POULAIN

Montpellier

 
Magento Community Magento Community
Magento Community
Magento Community
 
Otaugames
Sr. Member
 
Total Posts:  101
Joined:  2007-10-07
Troyes, France
 

Après l’installation de APC, tu n’as rien à modifier dans Magento. Pour faire fonctionner APC, seuls les paramètres du serveur Apache vont devoir être modifiés.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Bruntho
Jr. Member
 
Total Posts:  13
Joined:  2008-07-16
Toulouse
 

Bonsoir à tous,

Je tombe sur ce post car, après avoir eu quelques soucis avec mon install en ligne, je tente en local… Mais il est très lent ! Est ce que ce post a mené à une solution pour aller plus vite en local ?

Merci.

 
Magento Community Magento Community
Magento Community
Magento Community
 
guminator
Jr. Member
 
Total Posts:  1
Joined:  2008-09-05
 

Salut à tous.

J’ai découvert récemment Magento, et comme bien d’autre, j’ai été surpris de la puissance de celui-ci, mais aussi étonné de la lenteur en local (sous XP pro SP2b + easyPHP).

En parcourrant le web, pas mal de personne pose cette même question: “...c’est lent, est ce normal?...” constat auquel j’adhère.

Je suis tombé sur un post en anglais ou il était dit, entre autre, que Magento utilisait une base en “innodb”.

Après avoir mis mon nez dans la page de config mysql (fichier my.ini), j’ai activé certaine lignes concernant innodb et augmenté (doublé) les valeurs.

Après avoir rebooté le serveur, j’ai testé est constaté une accélération, attention c’est pas de la F1 quand même, mais avant, impossible d’enregistrer les groupes d’attributs si j’en mettais trop (+ de 10), je viens de tester en mettant tout les attributs et ça a passé au bout de quelques secondes (alors qu’il y avait apparemment abandon au bout de 30 seconds avant les changements).

Sur le bas du fichier, voici les lignes activées:

# Uncomment the following if you are using InnoDB tables
#innodb_data_home_dir = /usr/local/var/
#innodb_data_file_path = ibdata1:10M:autoextend
#innodb_log_group_home_dir = /usr/local/var/
#innodb_log_arch_dir = /usr/local/var/
# You can set .._buffer_pool_size up to 50 - 80 %
# of RAM but beware of setting memory usage too high
innodb_buffer_pool_size = 32M
innodb_additional_mem_pool_size = 4M
# Set .._log_file_size to 25 % of buffer pool size
#innodb_log_file_size = 5M
innodb_log_buffer_size = 16M
innodb_flush_log_at_trx_commit = 1
innodb_lock_wait_timeout = 120

NB: comme spécifié plus haut, j’ai en + doublé les valeurs des lignes activées

ps: l’activation des autres ligne de ce bloc ne permettent plus de démarrer mysql

Si quelqu’un veut tenter, pour voir si ce est une coïncidence ou pas, et si quelqu’un de plus avancé que moi saurai dire si ca à un impacte ou pas…

Bonne journée à tous

==================================================
edit:
petite précision, c’est surtout sur les enregistrements que j’ai constaté une amélioration.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 2 of 2