Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Is it recommended to use PHP 5.4 with Magento
 
PHP-Nitin
Jr. Member
 
Total Posts:  13
Joined:  2008-09-30
 

Hi All,

I am using PHP 5..4 with Magento and found everything fine. But I have seen magento system requirement http://www.magentocommerce.com/system-requirements where its recommended to use 5.3.

Should I degrade my PHP version or let it be and hope my Magento shop will work well.

Thank you.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Aspiration Host
Mentor
 
Avatar
Total Posts:  1287
Joined:  2008-05-09
Tampa, FL
 

PHP 5.4.x is not officially supported by Magento and you may run into some incompatibilities here and there (for example PHP 5.4.x’s SImpleXML implementation).

Is there any specific reason that you will need PHP 5.4.x?

You can play around with Magento and PHP 5.4.x if it is just a development store but for a production store, I recommend that you stick with PHP 5.3.x.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top