Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 1 of 2
Safe mode problems
 
Ulle
Jr. Member
 
Total Posts:  6
Joined:  2007-09-10
 

Hi Magento Team,

The product are looking very good so far grin

I am trying to install Magento, but it comes up with an error:

“Warning: set_time_limit() [function.set-time-limit]: Cannot set time limit in safe mode in”

I have talked to my hosting company and they confirmed, that the server are runing in “safe” mode.

Am I lost now? or do you guys have a solution?

/Ulrik

 
Magento Community Magento Community
Magento Community
Magento Community
 
Sousa
Guru
 
Avatar
Total Posts:  348
Joined:  2007-09-02
Porto, Portugal
 

it seems to be a big problem because set_time_limit() function don’t work, in any way no servers with php running in “safe mode”.
Check this link
http://www.php.net/manual/en/function.set-time-limit.php

im trying to find were the function is called on Magento.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Moshe
Magento Team
 
Avatar
Total Posts:  1770
Joined:  2007-08-07
Los Angeles
 

Magento will not run in safe mode.

This page: http://www.php.net/manual/en/features.safe-mode.functions.php shows that absolutely necessary functions are disabled in safe mode, such as:
header(), fopen(), move_uploaded_file(), unlink(), etc.

So removing set_time_limit() won’t help much..

 
Magento Community Magento Community
Magento Community
Magento Community
 
Moshe
Magento Team
 
Avatar
Total Posts:  1770
Joined:  2007-08-07
Los Angeles
 

I correct myself - some of these functions are not disabled but have limited functionality, which also might pose a problem in unexpected areas.

Is there anybody else that is restricted to running PHP in safe mode only?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Sousa
Guru
 
Avatar
Total Posts:  348
Joined:  2007-09-02
Porto, Portugal
 

i’m not but i will test

 
Magento Community Magento Community
Magento Community
Magento Community
 
Sousa
Guru
 
Avatar
Total Posts:  348
Joined:  2007-09-02
Porto, Portugal
 

Strange, i have a test server with wamp5, i enable safe mode everything its ok
No error.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Ulle
Jr. Member
 
Total Posts:  6
Joined:  2007-09-10
 

Hi,
here is my total error:

Warning: set_time_limit() [function.set-time-limit]: Cannot set time limit in safe mode in /var/www/www.domain.dk/www/app/code/core/Mage/Install/controllers/WizardController.php on line 21[0] in set_time_limit(0) in /var/www/www.domain.dk/www/app/code/core/Mage/Install/controllers/WizardController.php on line 21[1] in include("/var/www/www.domain.dk/www/app") in /var/www/www.domain.dk/www/app/code/core/Mage/Core/Controller/Varien/Router/Standard.php on line 121[2] in Mage_Core_Controller_Varien_Router_Standard->match(Zend_Controller_Request_Http) in /var/www/www.domain.dk/www/app/code/core/Mage/Core/Controller/Varien/Front.php on line 139[3] in Mage_Core_Controller_Varien_Front->dispatch() in /var/www/www.domain.dk/www/app/Mage.php on line 349[4] in Mage::run("base") in /var/www/www.domain.dk/www/index.php on line 27

Is that helpful for u guys?

/Ulrik

 
Magento Community Magento Community
Magento Community
Magento Community
 
RUDE
Jr. Member
 
Total Posts:  3
Joined:  2007-10-01
 

I’m having this exact problem too… I installed it perfectly in other server, but this one is giving me that error.

By the way, I can see the first screen perfectly under the error, but after I press “Continue” It gets a bigger error:

Warningset_time_limit() [function.set-time-limit]Cannot set time limit in safe mode in /mnt/san2/usr/home/mydomain.com/web/magento/app/code/core/Mage/Install/controllers/WizardController.php on line 20
[0] in set_time_limit
(120in /mnt/san2/usr/home/mydomain.com/web/magento/app/code/core/Mage/Install/controllers/WizardController.php on line 20
[1] in 
include("/mnt/san2/usr/home/mydomain.com/web/magento/app/code/core/Mage/Install/controllers/WizardCo"in /mnt/san2/usr/home/mydomain.com/web/magento/app/code/core/Mage/Core/Controller/Varien/Router/Standard.php on line 121
[2] in Mage_Core_Controller_Varien_Router_Standard
->match(Zend_Controller_Request_Httpin /mnt/san2/usr/home/mydomain.com/web/magento/app/code/core/Mage/Core/Controller/Varien/Front.php on line 139
[3] in Mage_Core_Controller_Varien_Front
->dispatch() in /mnt/san2/usr/home/mydomain.com/web/magento/app/Mage.php on line 356
[4] in Mage
::run("base"in /mnt/san2/usr/home/mydomain.com/web/magento/index.php on line 27

Warning
session_start() [function.session-start]Cannot send session cache limiter headers already sent (output started at /mnt/san2/usr/home/mydomain.com/web/magento/app/code/core/Mage/Core/functions.php:126in /mnt/san2/usr/home/mydomain.com/web/magento/app/code/core/Mage/Core/Model/Session/Abstract/Varien.php on line 49
[0] in session_start
() in /mnt/san2/usr/home/mydomain.com/web/magento/app/code/core/Mage/Core/Model/Session/Abstract/Varien.php on line 49
[1] in Mage_Core_Model_Session_Abstract_Varien
->start() in /mnt/san2/usr/home/mydomain.com/web/magento/app/code/core/Mage/Core/Model/Session.php on line 32
[2] in Mage_Core_Model_Session
->__construct(Array[0]in /mnt/san2/usr/home/mydomain.com/web/magento/app/code/core/Mage/Core/Model/Config.php on line 584
[3] in Mage_Core_Model_Config
->getModelInstance("core/session"Array[0]in /mnt/san2/usr/home/mydomain.com/web/magento/app/Mage.php on line 242
[4] in Mage
::getModel("core/session"Array[0]in /mnt/san2/usr/home/mydomain.com/web/magento/app/Mage.php on line 249
[5] in Mage
::getSingleton("core/session"in /mnt/san2/usr/home/mydomain.com/web/magento/app/code/core/Mage/Core/Controller/Varien/Action.php on line 86
[6] in Mage_Core_Controller_Varien_Action
->__construct(Zend_Controller_Request_HttpZend_Controller_Response_Httpin /mnt/san2/usr/home/mydomain.com/web/magento/app/code/core/Mage/Core/Controller/Varien/Router/Standard.php on line 124
[7] in Mage_Core_Controller_Varien_Router_Standard
->match(Zend_Controller_Request_Httpin /mnt/san2/usr/home/mydomain.com/web/magento/app/code/core/Mage/Core/Controller/Varien/Front.php on line 139
[8] in Mage_Core_Controller_Varien_Front
->dispatch() in /mnt/san2/usr/home/mydomain.com/web/magento/app/Mage.php on line 356
[9] in Mage
::run("base"in /mnt/san2/usr/home/mydomain.com/web/magento/index.php on line 27

exception 
'Zend_Controller_Response_Exception' with message 'Cannot send headers; headers already sent in /mnt/san2/usr/home/mydomain.com/web/magento/app/code/core/Mage/Core/functions.php, line 126' in /mnt/san2/usr/home/mydomain.com/web/magento/lib/Zend/Controller/Response/Abstract.php:265
Stack trace
:
#0 /mnt/san2/usr/home/mydomain.com/web/magento/lib/Zend/Controller/Response/Abstract.php(131): Zend_Controller_Response_Abstract->canSendHeaders(true)
#1 /mnt/san2/usr/home/mydomain.com/web/magento/app/code/core/Mage/Install/controllers/WizardController.php(120): Zend_Controller_Response_Abstract->setRedirect('http://lapendej...')
#2 /mnt/san2/usr/home/mydomain.com/web/magento/app/code/core/Mage/Core/Controller/Varien/Action.php(278): Mage_Install_WizardController->beginPostAction()
#3 /mnt/san2/usr/home/mydomain.com/web/magento/app/code/core/Mage/Core/Controller/Varien/Router/Standard.php(138): Mage_Core_Controller_Varien_Action->dispatch('beginPost')
#4 /mnt/san2/usr/home/mydomain.com/web/magento/app/code/core/Mage/Core/Controller/Varien/Front.php(139): Mage_Core_Controller_Varien_Router_Standard->match(Object(Zend_Controller_Request_Http))
#5 /mnt/san2/usr/home/mydomain.com/web/magento/app/Mage.php(356): Mage_Core_Controller_Varien_Front->dispatch()
#6 /mnt/san2/usr/home/mydomain.com/web/magento/index.php(27): Mage::run('base')
#7 {main}
 
Magento Community Magento Community
Magento Community
Magento Community
 
bonnevier
Jr. Member
 
Total Posts:  5
Joined:  2007-10-18
 

i’m having the same problems, but the thread seem to have died. can this be fixed even though i’m forced to use safe mode on?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Moshe
Magento Team
 
Avatar
Total Posts:  1770
Joined:  2007-08-07
Los Angeles
 

What do you mean by “forced” ?  Would you like to try PHP_CGI solution (http://www.magentocommerce.com/knowledge-base/entry/installing-magento-on-a-php4-server)

 
Magento Community Magento Community
Magento Community
Magento Community
 
bonnevier
Jr. Member
 
Total Posts:  5
Joined:  2007-10-18
 

by “forced” i mean that all the servers at one.com (where i have my domain) have safe mode turned on… of course i could change provider, but i rather solve the problem if i can.

the link you gave me showed how to run magento in php5, but i already have php5 at the server?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Moshe
Magento Team
 
Avatar
Total Posts:  1770
Joined:  2007-08-07
Los Angeles
 

php-cgi is a solution for any incompatible default php setup, which can be php4 or php5 with incompatible settings,
so if you can not disable safe_mode for default setup, php-cgi seems to me the easiest way to go.

 
Magento Community Magento Community
Magento Community
Magento Community
 
bonnevier
Jr. Member
 
Total Posts:  5
Joined:  2007-10-18
 

thanks, i’ll try it right away. i’ll be back…

 
Magento Community Magento Community
Magento Community
Magento Community
 
bonnevier
Jr. Member
 
Total Posts:  5
Joined:  2007-10-18
 

sigh… cgi was not supported at the host provider. sucks. gotta get myself another one. =/

 
Magento Community Magento Community
Magento Community
Magento Community
 
Cristian Balan
Jr. Member
 
Avatar
Total Posts:  29
Joined:  2008-02-11
Birmingham, UK
 

After install have this error:

Warningset_time_limit() [function.set-time-limit]Cannot set time limit in safe mode in /home/microhit/public_html/test/magento/app/code/core/Mage/Install/controllers/WizardController.php on line 20
[0] in set_time_limit
(120in /home/microhit/public_html/test/magento/app/code/core/Mage/Install/controllers/WizardController.php on line 20
[1] in 
include("/home/microhit/public_html/test/magento/app/code/core/Mage/Install/controllers/WizardController.php"in /home/microhit/public_html/test/magento/app/code/core/Mage/Core/Controller/Varien/Router/Standard.php on line 125
[2] in Mage_Core_Controller_Varien_Router_Standard
->match(Mage_Core_Controller_Request_Httpin /home/microhit/public_html/test/magento/app/code/core/Mage/Core/Controller/Varien/Front.php on line 147
[3] in Mage_Core_Controller_Varien_Front
->dispatch() in /home/microhit/public_html/test/magento/app/Mage.php on line 379
[4] in Mage
::run("base"in /home/microhit/public_html/test/magento/index.php on line 29

There was a problem proceeding with Magento installation
.

Please contact developers with error messages on this page.

exception 'Zend_Controller_Response_Exception' with message 'Cannot send headers; headers already sent in /home/microhit/public_html/test/magento/app/code/core/Mage/Core/functions.php, line 152' in /home/microhit/public_html/test/magento/lib/Zend/Controller/Response/Abstract.php:265
Stack trace
:
#0 /home/microhit/public_html/test/magento/lib/Zend/Controller/Response/Abstract.php(283): Zend_Controller_Response_Abstract->canSendHeaders(true)
#1 /home/microhit/public_html/test/magento/lib/Zend/Controller/Response/Abstract.php(711): Zend_Controller_Response_Abstract->sendHeaders()
#2 /home/microhit/public_html/test/magento/app/code/core/Mage/Core/Controller/Varien/Front.php(156): Zend_Controller_Response_Abstract->sendResponse()
#3 /home/microhit/public_html/test/magento/app/Mage.php(379): Mage_Core_Controller_Varien_Front->dispatch()
#4 /home/microhit/public_html/test/magento/index.php(29): Mage::run('base')
#5 {main}

exception 'Zend_Controller_Response_Exception' with message 'Cannot send headers; headers already sent in /home/microhit/public_html/test/magento/app/code/core/Mage/Core/functions.php, line 152' in /home/microhit/public_html/test/magento/lib/Zend/Controller/Response/Abstract.php:265
Stack trace
:
#0 /home/microhit/public_html/test/magento/lib/Zend/Controller/Response/Abstract.php(283): Zend_Controller_Response_Abstract->canSendHeaders(true)
#1 /home/microhit/public_html/test/magento/lib/Zend/Controller/Response/Abstract.php(711): Zend_Controller_Response_Abstract->sendHeaders()
#2 /home/microhit/public_html/test/magento/app/code/core/Mage/Core/Controller/Varien/Front.php(156): Zend_Controller_Response_Abstract->sendResponse()
#3 /home/microhit/public_html/test/magento/app/Mage.php(379): Mage_Core_Controller_Varien_Front->dispatch()
#4 /home/microhit/public_html/test/magento/index.php(29): Mage::run('base')
#5 {main}
So, the solution is “Installing Magento on a PHP4 server” http://www.magentocommerce.com/knowledge-base/entry/installing-magento-on-a-php4-server ?
 
Magento Community Magento Community
Magento Community
Magento Community
 
NinjaTech
Jr. Member
 
Avatar
Total Posts:  26
Joined:  2008-03-28
 

My safe mode is off, on my second website setting I get an endless session_start error, that keeps refreshing non-stop. I also get this on my main website:

Warning: session_start() [function.session-start]: open(/home/jumbokey/public_html/var/session/sess_30a3b71f7dc7e385dbb1fd6b036bde8e, O_RDWR) failed: Permission denied (13) in /home/jumbokey/public_html/app/code/core/Mage/Core/Model/Session/Abstract/Varien.php on line 61[0] in session_start() in /home/jumbokey/public_html/app/code/core/Mage/Core/Model/Session/Abstract/Varien.php on line 61[1] in Mage_Core_Model_Session_Abstract_Varien->start("frontend") in /home/jumbokey/public_html/app/code/core/Mage/Core/Model/Session/Abstract/Varien.php on line 69[2] in Mage_Core_Model_Session_Abstract_Varien->init("core", “frontend") in /home/jumbokey/public_html/app/code/core/Mage/Core/Model/Session/Abstract.php on line 36[3] in Mage_Core_Model_Session_Abstract->init("core", “frontend") in /home/jumbokey/public_html/app/code/core/Mage/Core/Model/Session.php on line 33[4] in Mage_Core_Model_Session->__construct(Array[1]) in /home/jumbokey/public_html/app/code/core/Mage/Core/Model/Config.php on line 608[5] in Mage_Core_Model_Config->getModelInstance("core/session", Array[1]) in /home/jumbokey/public_html/app/Mage.php on line 292[6] in Mage::getModel("core/session", Array[1]) in /home/jumbokey/public_html/app/Mage.php on line 306[7] in Mage::getSingleton("core/session", Array[1]) in /home/jumbokey/public_html/app/code/core/Mage/Core/Controller/Varien/Action.php on line 367[8] in Mage_Core_Controller_Varien_Action->preDispatch() in /home/jumbokey/public_html/app/code/core/Mage/Core/Controller/Front/Action.php on line 39[9] in Mage_Core_Controller_Front_Action->preDispatch() in /home/jumbokey/public_html/app/code/core/Mage/Core/Controller/Varien/Action.php on line 334[10] in Mage_Core_Controller_Varien_Action->dispatch("view") in /home/jumbokey/public_html/app/code/core/Mage/Core/Controller/Varien/Router/Standard.php on line 150[11] in Mage_Core_Controller_Varien_Router_Standard->match(Mage_Core_Controller_Request_Http) in /home/jumbokey/public_html/app/code/core/Mage/Core/Controller/Varien/Front.php on line 147[12] in Mage_Core_Controller_Varien_Front->dispatch() in /home/jumbokey/public_html/app/Mage.php on line 424[13] in Mage::run("default") in /home/jumbokey/public_html/index.php on line 40

I don’t know, my /var has all permissions of 777, maybe it is suhosin, but this just started.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 1 of 2