Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Google Analytics code is not showing up. 
 
Mootrealm
Sr. Member
 
Avatar
Total Posts:  150
Joined:  2007-09-14
San Francisco, CA
 

I have google analytics turned on and my account number plugged in, but the code is not showing up in the front end for some reason.

 
Magento Community Magento Community
Magento Community
Magento Community
 
wsj3
Guru
 
Avatar
Total Posts:  521
Joined:  2008-07-13
Portland, OR
 

I’m having this same problem. Does anyone know if the code should appear when you view source for any page?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Mootrealm
Sr. Member
 
Avatar
Total Posts:  150
Joined:  2007-09-14
San Francisco, CA
 

Yes it should.

 
Magento Community Magento Community
Magento Community
Magento Community
 
wsj3
Guru
 
Avatar
Total Posts:  521
Joined:  2008-07-13
Portland, OR
 

Mootrealm, are you using an off the shelf template/theme? I’m using modern, but have tweaked it. Wasn’t having a problem with it until I switched to 1.3.1

 
Magento Community Magento Community
Magento Community
Magento Community
 
Mootrealm
Sr. Member
 
Avatar
Total Posts:  150
Joined:  2007-09-14
San Francisco, CA
 

I am using a heavily altered version of the default theme.

 
Magento Community Magento Community
Magento Community
Magento Community
 
MathieuF
Sr. Member
 
Total Posts:  141
Joined:  2009-03-12
Montreal, Canada
 

I’m having the same problem, using 1.3.2.3, using a slighly modified default theme. Anyone found a solution ?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Mootrealm
Sr. Member
 
Avatar
Total Posts:  150
Joined:  2007-09-14
San Francisco, CA
 

Make sure you have this line of code at the bottom of your template pages.

<?php echo $this->getChildHtml('before_body_end'?>

This is what it should look like…

<?php echo $this->getChildHtml('before_body_end'?>
<?php 
echo $this->getAbsoluteFooter() ?>
</body>
</
html>
 
Magento Community Magento Community
Magento Community
Magento Community
 
MathieuF
Sr. Member
 
Total Posts:  141
Joined:  2009-03-12
Montreal, Canada
 

That’s my problem. It’s there already!

I’m using most of the original files, so it shouldn’t be an issue. Any other tip ?

In the meantime, I manually added the code in the footer_links, I don’t like the fact that it doesn’t show at the right place.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Mootrealm
Sr. Member
 
Avatar
Total Posts:  150
Joined:  2007-09-14
San Francisco, CA
 

I don’t have any other tips other than obvious stuff like making sure your settings are correct for the store view in question.

What do you mean by ‘right place’. In theory it can go any where. The only reason it is suggested that it go at the bottom is so it will be the last thing to load thus it does not slow down your page.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top