Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 1 of 8
Can’t login to admin after installation. 
 
Joley
Jr. Member
 
Avatar
Total Posts:  24
Joined:  2007-11-01
Sweden, Västerås
 

Hey dear Magento Team,

This is the first time im getting problem with a Magento release. I don’t see any wrong in what i do when i try to install the latest release of magento. I’ve always did the same way with earlier versions, but with the newest one im getting a very annoying problem.

Well, after installation of the latest release, when i try to login to the admin, it doesn’t work at all. Im 100% sure that i write the correct username and password (lol), still dont work. It just redirects me to the same page without warnings etc, the strange thing is if i put a wrong username/password, i get “access denied”.

I really dont have any clue what could been wrong, so it would be interesting to know what the problem could be.

Sirencly
Joley

 
Magento Community Magento Community
Magento Community
Magento Community
 
Rindviech
Jr. Member
 
Avatar
Total Posts:  11
Joined:  2008-02-08
 

same problem here with wamp5

 
Magento Community Magento Community
Magento Community
Magento Community
 
Joley
Jr. Member
 
Avatar
Total Posts:  24
Joined:  2007-11-01
Sweden, Västerås
 

Oh yes, i forget to tell that the platforms i use is on Windows XP together with XAMPP… But i’d never got this problem with other releases, any ideas?

 
Magento Community Magento Community
Magento Community
Magento Community
 
cafs
Jr. Member
 
Total Posts:  9
Joined:  2007-11-01
 

Í have the exact same problem. Windows XP and XAMPP. I think this is a XAMPP related problem. I installed Magento under Ubuntu + LAMPP, and I had this problem too. I’ll keep checking…

 
Magento Community Magento Community
Magento Community
Magento Community
 
lotusseedsD
Mentor
 
Avatar
Total Posts:  1144
Joined:  2007-08-31
 

davy - 09 March 2008 01:59 AM
Same error. login/password correct (otherwise I get Access denied error) but I ca’t get past the login page.
Installed new version (0.8.1720) from scratch on windows

Oh, I see. I guess you installed magento on localhost and are trying to access it like http://localhost/magento. But due to standard restrictions browsers don’t save cookie for domains with no dots in domain name. You can try to access it with http://localhost.com/magento or whatever else if you write it to your hosts file on Window

http://www.magentocommerce.com/boards/viewthread/4198/P0/

 
Magento Community Magento Community
Magento Community
Magento Community
 
bigtuna
Jr. Member
 
Total Posts:  20
Joined:  2007-11-09
Atlanta, GA USA
 

If this is a standard restriction, what changed?  This problem did not occur for the above users with earlier releases, and I’ve got the same issue now as well.  Never had an issue like this with the last 4 releases....

 
Magento Community Magento Community
Magento Community
Magento Community
 
bigtuna
Jr. Member
 
Total Posts:  20
Joined:  2007-11-09
Atlanta, GA USA
 

Based on info in another post, I used http://127.0.0.1/ instead of http://localhost and as able to login.  Still not sure why the change, but there’s the solution for local development…

 
Magento Community Magento Community
Magento Community
Magento Community
 
Rindviech
Jr. Member
 
Avatar
Total Posts:  11
Joined:  2008-02-08
 

try the following - edit your hosts file - wirte after localhost.com instead of localhost. Save the file and reboot.
After that the login will work.

In this version the login is handeled by a cookie and browsers normally don’t accept cookies from a TLD (in this case localhost is a TLD)

 
Magento Community Magento Community
Magento Community
Magento Community
 
cafs
Jr. Member
 
Total Posts:  9
Joined:  2007-11-01
 

Hi all,

Thanks for everyone’s help. It worked by accessing admin pagen through “http://127.0.0.1/magento/index.php/admin”.

Nice job everyone!

Thanks.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Mr K
Jr. Member
 
Total Posts:  11
Joined:  2008-02-09
 

oh this is GOLD ...

Funnily enough, if you develop using sessions rather than cookies (which by the way the browser saves a session key as a cookie) the browser CAN support it without the dots

Still a quick tinker to my apache conf file & local hosts and away we go smile thank you

 
Magento Community Magento Community
Magento Community
Magento Community
 
kirederf
Jr. Member
 
Total Posts:  10
Joined:  2008-01-30
 

Same issue here on OSX with MAMP. Adding a “.local” to my vhosts fixed the problem. Thanks guys smile

 
Magento Community Magento Community
Magento Community
Magento Community
 
tiberius
Jr. Member
 
Avatar
Total Posts:  30
Joined:  2008-04-13
 

I have installed Magento on my PC with XAMPP and I cannot login to admin. Where is the admin stored because I do not have a folder labelled admin?

 
Magento Community Magento Community
Magento Community
Magento Community
 
kirederf
Jr. Member
 
Total Posts:  10
Joined:  2008-01-30
 

There is no folder admin. You can either access admin through

http://pathToYourMagentoInstallation/index.php/admin/

or if you enabled clean urls during installation process

http://pathToYourMagentoInstallation/admin/

HTH

 
Magento Community Magento Community
Magento Community
Magento Community
 
Bao
Jr. Member
 
Total Posts:  2
Joined:  2009-02-11
 

try this simple way:

http://127.0.0.1/magento/index.php/admin

 
Magento Community Magento Community
Magento Community
Magento Community
 
sharma chelluri
Jr. Member
 
Total Posts:  2
Joined:  2008-01-03
 

NOT WORKING MAN!!.

Any centralized topic on this ?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Designx9
Jr. Member
 
Total Posts:  1
Joined:  2009-02-19
 

Working like a treat!!

Change localhost to http://127.0.0.1/magento/admin

If you have different port http://127.0.01:portnumber/magento/admin.

Thanks alot for everyone’s help. Need to look for permanent solution.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 1 of 8