Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

wesite go down frequently - Please help! 
 
wyfwyf112
Jr. Member
 
Total Posts:  3
Joined:  2010-05-07
 

Hello guys,

Our magento website goes down frequently these days, here are a few error log:

a:4:{i:0;s:108:\\\"SQLSTATE[42000] [1203] User our_website already has more than \\\’max_user_connections\\\’ active connections\\\";i:1;s:2993:\\\"#0 /home/cosplays/public_html/lib/Zend/Db/Adapter/Pdo/Mysql.php(96): Zend_Db_Adapter_Pdo_Abstract->_connect()
#1 /home/cosplays/public_html/lib/Varien/Db/Adapter/Pdo/Mysql.php(313): Zend_Db_Adapter_Pdo_Mysql->_connect()
#2 /home/cosplays/public_html/lib/Zend/Db/Adapter/Abstract.php(459): Varien_Db_Adapter_Pdo_Mysql->_connect()
#3 /home/cosplays/public_html/lib/Zend/Db/Adapter/Pdo/Abstract.php(238): Zend_Db_Adapter_Abstract->query(\\\’SET NAMES utf8\\\’, Array)

We contacted the hosting company, and they said:

The server has been rebooted, but after this took place there are a lot of connections to the server that is causing max user connections error and the load the to be extremely high on the server, which is the reason why the server had to be rebooted. It look like you are being DDOS or excessively crawled.

Our website has 3000 - 4000 visits per day, and here is our hosting information:

Quad Core
Intel Xeon L5420
2.50 GHz Processor
32 GB RAM ECC
500 GB SATA

Do we need to upgrade our server for better CPU or something?
And anyone can kindly tell us where to start to solve this problem?

Thank you guys very much!

 
Magento Community Magento Community
Magento Community
Magento Community
 
MagenX
Enthusiast
 
Total Posts:  791
Joined:  2008-05-26
Dublin
 

hi
just a quick solution:
disable persistent mysql connections, and/or increase max_connections, and install varnish cache,
to debug this deeper you need to ffind out whats going on and check your configuration, mysql config, etc

cheers

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top