Magento Forum

   
No input file error back godaddy hosting
 
jlmayer
Jr. Member
 
Total Posts:  3
Joined:  2013-05-29
 

Hi Everyone,

I have Godaddy hosting and previously had the no input file specified error which was fixed successfully with this trick:

Login to your Godaddy Account.  Click on your hosting account.
Go to Settings > File Extensions Management

and change .php and .php5 to run under PHP5.2X (instead of PHP5.2xFastCGI)

But godaddy has removed the file extensions management from settings, and changing it with code in htaccess. as they specify,
(for example AddHandler x-httpd-php5-2x .php) doesnt do anything. It seems this fast CGI is causing problems but I am not sure how to change it? Anyone got any tips?

Many thanks!

 
Magento Community Magento Community
Magento Community
Magento Community
 
bobbydank
Jr. Member
 
Total Posts:  2
Joined:  2013-02-12
 

Here is what I did to fix it. First go to the admin panel and find Programming Languages under settings. Make sure PHP 5.2 is selected.

Now add the following to your .htaccess file (I put this at the top)

RewriteEngine On
RewriteCond 
%{DOCUMENT_ROOT}%{REQUEST_URI} !-f
RewriteRule 
^.+.php$ /bogusfile

Options 
-MultiViews

If your install is inside a folder in the webroot (for example - http://www.yoursite.com/store), make sure you have this in the htaccess also:

RewriteBase /store/

Now, in the webroot, there should be a php.ini file. You need to rename that file php5.ini and add this bit of code in there

cgi.fix_pathinfo 1

Once that is done, here is the annoying part… you have to wait. The reason why is this changes require an apache restart to take effect. Godaddy doesn’t allow user restarts on shared web hosting, so you have to wait for the server cycle which can take up to a few hours.

Help everything works for ya.

 
Magento Community Magento Community
Magento Community
Magento Community
 
jlmayer
Jr. Member
 
Total Posts:  3
Joined:  2013-05-29
 

Thanks so much for responding! looks like it got fixed by

changing the programming language from php5.3 to 5.2

adding this line to my php5.ini (had already renamed in a previous attempt to fix it)

cgi.fix_pathinfo 1

even worked instantly! Thanks again!!

 
Magento Community Magento Community
Magento Community
Magento Community
 
magesolutions
Sr. Member
 
Avatar
Total Posts:  88
Joined:  2013-02-03
 
juliamays - 21 June 2013 10:11 AM

Hi Everyone,

I have Godaddy hosting and previously had the no input file specified error which was fixed successfully with this trick:

Login to your Godaddy Account.  Click on your hosting account.
Go to Settings > File Extensions Management

and change .php and .php5 to run under PHP5.2X (instead of PHP5.2xFastCGI)

But godaddy has removed the file extensions management from settings, and changing it with code in htaccess. as they specify,
(for example AddHandler x-httpd-php5-2x .php) doesnt do anything. It seems this fast CGI is causing problems but I am not sure how to change it? Anyone got any tips?

Many thanks!

Since it doesn’t design to work for magento, I believe it will happen a lot of other problems later on. You should choose a magento hosting provider instead of using goddady without any experience in magento hosting and they even have no magento hosting package. The truth thing you can see now is you can’t send them any ticket support relate to magento because they have no idea on it.

I highly recommend you choose another hosting company. As I usually use is SiteGround magento hosting package.

 
Magento Community Magento Community
Magento Community
Magento Community
 
rangnath
Jr. Member
 
Total Posts:  7
Joined:  2013-12-12
 

Hello,

I have got the solution on this website must read No Input File Specified Error Hosted By Godaddy Magento Website.
Or you can read here Expertwebadvisor.

Thanks

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
    Back to top