Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Problema con installazione Magento in locale con MAMP
 
davide90
Jr. Member
 
Total Posts:  18
Joined:  2011-09-14
 

Salve a tutti, sto provando a installare Magento in locale con MAMP, ma dopo aver settato la cartella per lettura e scrittura, ho sempre l’errore :
Errore HTTP 500 (Internal Server Error): Si è verificata una condizione imprevista durante il tentativo del server di soddisfare la richiesta.
Sapete aiutarmi ?

PS : ho provato con altri CMS diversi da Magento e funzionano senza problemi, quindi oltre a settare i permessi non saprei cosa fare.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Black Cat
Moderator
 
Avatar
Total Posts:  3481
Joined:  2008-02-14
Assemini / Cagliari (Italy)
 

Strano in genere MAMP tiene Magento subito senza sbattimenti.

Fai così, da php.ini
imposta
display_errors = On
error_reporting = E_ALL | E_STRICT

e facci sapere l’errore che ti da.

Prima però fai una prova veloce aumentando il memory limit del php, magari la tua versione è impostata su un valore basso

 
Magento Community Magento Community
Magento Community
Magento Community
 
davide90
Jr. Member
 
Total Posts:  18
Joined:  2011-09-14
 

Grazie per la risposta, comunque sono andato su MAMP ed ho impostato tutti i file ini con le caratteristiche che mi hai dato tu ( c’erano varie versioni di php e le ho impostate su tutte le versioni ), ho riavviato MAMP , ma ho sempre lo stesso problema...spero di aver capito correttamente smile

 
Magento Community Magento Community
Magento Community
Magento Community
 
Black Cat
Moderator
 
Avatar
Total Posts:  3481
Joined:  2008-02-14
Assemini / Cagliari (Italy)
 

i codici che ti ho dato servono per mostrare l’errore.

Per risolvere ti avevo suggerito di aumentare il memory limit. A quando l’hai aumentato?

 
Magento Community Magento Community
Magento Community
Magento Community
 
davide90
Jr. Member
 
Total Posts:  18
Joined:  2011-09-14
 

Ciao, grazie per la risposta, comunque sono nuovo su MAMP, mi potresti dire da dove aumento la Memory Unit? Grazie ancora

 
Magento Community Magento Community
Magento Community
Magento Community
 
davide90
Jr. Member
 
Total Posts:  18
Joined:  2011-09-14
 

Sono riuscito a cambiare la memory_limit, e anche ad impostare altri file php.ini per gli errori. Ho avuto questo errore :
Fatal error: Method Varien_Object::__tostring() cannot take arguments in /Applications/MAMP/htdocs/magento/lib/Varien/Object.php on line 488

Ho seguito una guida online ed ho sostituito :

File: /lib/Varien/Object.php (Line 484)

Cambiato da :

public function ___toString(array $arrAttributes=array(),$valueSeparator=’,’)

A :

public function __invoke(array $arrAttributes=array(),$valueSeparator=’,’)

Ma ho avuto un altro errore :

Fatal error: Call to a member function getFrontNameByRoute() on a non-object in /Applications/MAMP/htdocs/magento/app/code/core/Mage/Core/Controller/Varien/Front.php on line 180

Questo non lo riesco a risolvere e non vorrei fare altri cambiamenti perchè non so se quello precedente è corretto. Spero possa aiutarmi.
Grazie

 
Magento Community Magento Community
Magento Community
Magento Community
 
Black Cat
Moderator
 
Avatar
Total Posts:  3481
Joined:  2008-02-14
Assemini / Cagliari (Italy)
 

uhm ma non è che hai impostato i permessi in maniera errata?
In genere i permessi vanno bene da subito senza modificare nullla.

Fai così, rasa installazione e database e riprova seguendo la via più generale possibile senza toccare nulla.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top