Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

store url angeben funktioniert nicht
 
andi
Member
 
Avatar
Total Posts:  54
Joined:  2007-09-19
Munich
 

Hallo,

will im Theme mit

<a href="{{store url=""}}test">test</a>

einen Link setzen, leider funktioniert das nicht, es wird auf “{{store url=” gelinkt
Wenn ich den o.g. Code jedoch in einem statischen Block speichere funktioniert alles.

Was mache ich falsch bzw. wo könnte der Fehler liegen?

Magentoversion ist 1.3.1.1

 
Magento Community Magento Community
Magento Community
Magento Community
 
epromer
Member
 
Total Posts:  62
Joined:  2008-04-04
Germany, Schiffweiler
 

Hallo Andi,

die Ersetzung der geschweiften Klammern funktioniert nur in den CMS-Seiten und Blöcken.

In den Layout-Dateien (.phtml) kannst Du die Store-URL direkt mit PHP erhalten dazu einfach

<?php echo $this->getUrl(''?>
verwenden.

Gruß
Thomas

 
Magento Community Magento Community
Magento Community
Magento Community
 
andi
Member
 
Avatar
Total Posts:  54
Joined:  2007-09-19
Munich
 

Hallo Thomas,

vielen Dank, Dein Code-Schnipsel funktioniert gut!

In dem Buch “Online Shop mit Magento” von Roman Zenner wird auf Seite 175 die o.g. Variante beschrieben, welche nicht (mehr?) funktioniert. Das Buch bezieht sich auf Magento 1.2.1

 
Magento Community Magento Community
Magento Community
Magento Community
 
epromer
Member
 
Total Posts:  62
Joined:  2008-04-04
Germany, Schiffweiler
 

OK, das war mir jetzt neu, dass das einmal funktioniert hatte.
Aber ganz ehrlich, ich wäre nie auf die Idee gekommen die Klammern in einer Datei zu verwenden, welche durch den PHP-Parser gejagt wird.

Das ganze wurde bestimmt im Zuge einer Performanceoptimierung entfernt. War ja eh überflüssig und meines Wissens nach in keinem Template vorhanden.

Gruß
Thomas

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top