Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

I got Error massage during installation
 
iranibazar
Jr. Member
 
Avatar
Total Posts:  8
Joined:  2008-02-06
 

Hello . I got Error massage during installation :
PHP Extension “pdo_mysql” must be loaded
PHP Extension “mcrypt” must be loaded
PHP Extension “curl” must be loaded

Please Guide me !
I Have : appserv-win32-2.5.9

 
Magento Community Magento Community
Magento Community
Magento Community
 
srinigenie
Guru
 
Avatar
Total Posts:  539
Joined:  2008-02-04
 

cool smile  welcome to the world of Magento ... Magento needs these PHP extensions as a pre-requisite. If you are trying this on a hosted environment, ask your webhost to enable these PHP extensions.

 
Magento Community Magento Community
Magento Community
Magento Community
 
iranibazar
Jr. Member
 
Avatar
Total Posts:  8
Joined:  2008-02-06
 

Thank You !
But I’m Working On Localhost . ( Not Web).

 
Magento Community Magento Community
Magento Community
Magento Community
 
iranibazar
Jr. Member
 
Avatar
Total Posts:  8
Joined:  2008-02-06
 

Won’t you Help me?!

 
Magento Community Magento Community
Magento Community
Magento Community
 
GizzmoAsus
Jr. Member
 
Avatar
Total Posts:  17
Joined:  2008-02-21
Blackburn, UK
 

Need a bit more information that that mate, i.e. OS etc

 
Magento Community Magento Community
Magento Community
Magento Community
 
iranibazar
Jr. Member
 
Avatar
Total Posts:  8
Joined:  2008-02-06
 

Windows Xp SP2
IE 7.0.5730.13

 
Magento Community Magento Community
Magento Community
Magento Community
 
Lior
Magento Team
 
Avatar
Total Posts:  293
Joined:  2007-09-24
 

Some more info will help
1) Magento version?
2) PHP version?
3) MySQL version?
4) If you can show the phpinfo details

 
Magento Community Magento Community
Magento Community
Magento Community
 
iranibazar
Jr. Member
 
Avatar
Total Posts:  8
Joined:  2008-02-06
 

Magento : ver. Beta 0.8.17240
The AppServ Open Project - 2.5.9 for Windows

phpMyAdmin Database Manager Version 2.10.2
PHP Information Version 5.2.3
About AppServ Version 2.5.9 for Windows
AppServ is a merging open source software installer package for Windows includes :
Apache Web Server Version 2.2.4
PHP Script Language Version 5.2.3

MySQL Database Version 5.0.45

phpMyAdmin Database Manager Version 2.10.2

 
Magento Community Magento Community
Magento Community
Magento Community
 
iranibazar
Jr. Member
 
Avatar
Total Posts:  8
Joined:  2008-02-06
 

????

 
Magento Community Magento Community
Magento Community
Magento Community
 
Airforce111
Sr. Member
 
Avatar
Total Posts:  100
Joined:  2008-01-31
 

If you are running your own localhost, you need to install the extensions listed above in your warnings (pdo_mysql, mcrypt, curl) along with all its dependencies. If you do not know how to do that, then I suggest you either get a host that meets the requirements of magento if you can afford it to test run magento OR start reading and learning material on how to setup your own web server environments. I hope I don’t come across as intimidating but there are many environment configurations out there and it isn’t possible for us here to guide you all the way on the environment setup.

So, essentially, you need to enable all the extensions it is complaining about, including its dependencies. For example, pdo_mysql requires the PDO extension as a dependency. Hope this helps.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top