Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Non visualizzo le immagini dei prodotti dopo un trasferimento
 
Soniag001
Member
 
Total Posts:  51
Joined:  2012-02-19
 

Ho traserito da un server ad un altro il mio magento e sostanzialmente sembra andare, il problema è che non visualizza tutte le immagini che ho caricato dal backend ossia: immagini dei prodotti, slider e immagine di categoria.
Ovviamente ho vuotato la cache e reindicizzato tutto, ho provato a cancellare la cartella var/cache ricancellata la cache e reindicizzato, disabilitato la cache e reindicizzato ma nulla…
La cosa strana è che andando a vedere il percorso di una mia immagine dal codice sorgente è:

http://e-shop.miosito.com/media/catalog/product/cache/1/small_image/135x135/9df78eab33525d08d6e5fb8d27136e95/1/8/1845.jpg

Sono quindi andata via ftp in quella cartella e l’immagine c’è!!!

---

Inoltre dai log del sistema ho questi errori

[Tue Jun 18 10:08:12 2013] [alert] [client 62.173.184.122:51457] - www.miosito.com - /web/htdocs/miosito.com/home/media/.htaccess: Option All not allowed here, referer http://e-shop.miosito.com/

Sonia

 
Magento Community Magento Community
Magento Community
Magento Community
 
Black Cat
Moderator
 
Avatar
Total Posts:  3481
Joined:  2008-02-14
Assemini / Cagliari (Italy)
 

potrebbe essere un errata configurazione del file htaccess oppure i permessi della cartella media non impostati correttamente

 
Magento Community Magento Community
Magento Community
Magento Community
 
w a v i
Sr. Member
 
Avatar
Total Posts:  155
Joined:  2007-09-07
Varese
 

Hai cancellato la cache, .. anche Flush Catalog Images Cache (system > Cache Managment) ?
..se non hai fatto meglio farlo anzi visto che ci sei:

Flush Cache storage
Flush Catalog Images Cache
Flush Javascript/css Cache

Se questo non ripristina come illustrato nel post qui sopra, verificare i permessi della cartella directory \"media\"

se puoi accedere via SSH posizionati nella directory di magento e digita :

chmod -R o+w media

oppure se non è possibile via SSH utilizza FTP (se client ftp permette)

seleziona la cartella media dai i permessi 777 -R (-R = Recursive)

...poi vediamo

 
Magento Community Magento Community
Magento Community
Magento Community
 
Soniag001
Member
 
Total Posts:  51
Joined:  2012-02-19
 

i permessi ho verificato che sono a 777 e tutte le operazioni citate sono state fatte a questo punto penso che il problema sia nel file .htaccess

il file della cartella media è questo:

Options All -Indexes
<IfModule mod_php5.c>
php_flag engine 0
</IfModule>

AddHandler cgi-script .php .pl .py .jsp .asp .htm .shtml .sh .cgi
Options 
-ExecCGI

<IfModule mod_rewrite.c>

############################################
## enable rewrites

    
Options +FollowSymLinks
    RewriteEngine on

############################################
## never rewrite for existing files
    
RewriteCond %{REQUEST_FILENAME} !-f

############################################
## rewrite everything else to index.php

    
RewriteRule .* ../get.php [L]
</IfModule>
 
Magento Community Magento Community
Magento Community
Magento Community
 
Soniag001
Member
 
Total Posts:  51
Joined:  2012-02-19
 

Aggiorno… il problema di visualizzazione si è risolto eliminando il file .htaccess… in questo modo le immagini le visualizzo ma non si caricano più!

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top