Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

BR - duvidas - iniciantes
 
gutogodoy
Jr. Member
 
Total Posts:  18
Joined:  2009-05-15
 

bom dia pessoal, quando vou dar continuidade ao processo de liberação de uma compra, na emissão da fatura e da postagem, aparece as seguintes mensagens:

Não foi possível salvar fatura - Não foi possível fazer fatura para compra

Não foi possível salvar postagem. - Não foi possível fazer entrega para compra.

e o cliente não recebe e-mails sobre a fatura e sobre a postagem.

o que pode estar errado?

agradeço desde já a ajuda de vocês.

guto

 
Magento Community Magento Community
Magento Community
Magento Community
 
Adriano Aguiar
Moderator
 
Avatar
Total Posts:  343
Joined:  2008-08-26
Sao Paulo
 

@gutogodoy Você instalou algum recurso não padrão pelo magento-connect?

 
Magento Community Magento Community
Magento Community
Magento Community
 
gutogodoy
Jr. Member
 
Total Posts:  18
Joined:  2009-05-15
 

oi adriano,

instalei o modulo de correio, boleto, um chat que não funciona, nostrssconect… acho que é isso…

algum deste pode estar causando isto?

obrigado,

abraço

guto

 
Magento Community Magento Community
Magento Community
Magento Community
 
Cesar Scur
Jr. Member
 
Avatar
Total Posts:  8
Joined:  2009-03-31
 

Estou tendo o mesmo problema.
Acredito que o problema esteja vinculado ao plugin de pagamento via boleto.

Qual vc esta utilizando?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Cesar Scur
Jr. Member
 
Avatar
Total Posts:  8
Joined:  2009-03-31
 

Acabei de realizar alguns testes e na verdade o problema o corre mesmo quando eu crio uma compra pelo backend utilizando o metodo de pagamento “Check / Money order”
O erro apenas aparece quando a caixa “Cópia do Email de Fatura “ está selecionada ao criar uma fatura(invoice).
O erro:
o Não foi possível salvar fatura
o Não foi possível fazer fatura para compra

Ainda sim a fatura é criada, mas o status da compra não é atualizado para processado e o email não é enviado.

Alguma sugestão? Existe algum problema relacionado que já tenha sido resolvido em uma nova versão(utilizo v1.2.x)?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Cesar Scur
Jr. Member
 
Avatar
Total Posts:  8
Joined:  2009-03-31
 

A release notes da vers 1.3 inclui “Fixed #11920: Sales -> Invoices -> Crash”
Mas não tenho como saber se essa correção é realmente o que eu preciso =/

http://www.magentocommerce.com/bug-tracking/issue?issue=11920
A issue foi deletada? Existe outra maneira de consultar essas alterações q não a release notes ou como ver o que essa issue trata??

 
Magento Community Magento Community
Magento Community
Magento Community
 
gutogodoy
Jr. Member
 
Total Posts:  18
Joined:  2009-05-15
 

pois é cesar, o status não é atualizado e nem o email enviado. ainda não descobri como resolver. achei que eram alguns modulos instalados, desistalei mas continua com o problema. se você descobrir algo por favor me avise.

att

guto

 
Magento Community Magento Community
Magento Community
Magento Community
 
gutogodoy
Jr. Member
 
Total Posts:  18
Joined:  2009-05-15
 

a propósito cesar, no meu caso ocorre em qualquer forma de pagamento.

abraços

guto

 
Magento Community Magento Community
Magento Community
Magento Community
 
Adriano Aguiar
Moderator
 
Avatar
Total Posts:  343
Joined:  2008-08-26
Sao Paulo
 

Pois é @gutogodoy tome cuidado em trabalhar com aplicações sem uma revisão, disponibilizada no fórum nacional e internacional… não pela falta de capacidade técnica dos seus criadores, mas por não estarem passando por um processo de revisão que pode acontecer disponibilizando isso no próprio magento connect. Normalmente as pessoas acabam encontrando n problemas após a instalação de alguns recursos, isso é comum devido ao comportamento da aplicação por versão ou pela forma que foi proposto, pois essa aplicação pode ter tido n mudanças de configurações padrão, que pode conflitar com as propostas que a propria extensão espera encontrar de uma aplicação instalada e configurada padrão. Sempre procuro estudar numa aplicação adicional, com ambiente padrão magento, para tomar minhas conclusões sobre o comportamento do mesmo. Valeu ai pela força @Cesar! wink Coloca um print das tuas dúvidas aqui… por que não entendi o bug tracking que tu publicou, tu publicou uma falha e removeram? Tem que ver se realmente era um bug amigo. Publicar algo no issue do bug tracking tem que ter certeza do que está reportando.

Valeu!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Cesar Scur
Jr. Member
 
Avatar
Total Posts:  8
Joined:  2009-03-31
 

Resolvi o problema =]
Apos identificar a fonte do problema no invoiceController(351) e deixar o erro um pouco mais claro, consegui encontrar este site que explica de maneira clara como resolver o problema:

http://gabriel.indexainternet.com.br/tag/e-mails-transacionais/

Contudo, não consegui identificar se o problema foi corrigido nas ultimas versões do Magento por problemas que eu prefiro nem comentar.
Recomendo que vc faça isso antes de tentar seguir o que o site indica Guto.

Grato,
Cesar Scur

 
Magento Community Magento Community
Magento Community
Magento Community
 
Cesar Scur
Jr. Member
 
Avatar
Total Posts:  8
Joined:  2009-03-31
 

Adriano,

O bug que eu me referi é um bug que esta na release notes da versão 1.3 do Magento como um bug corrigido. Porem este bug não esta mais acessível pelo bug tracker, que é uma pena, pois perdemos, assim a referencia para o problema resolvido. Ou seja, eu n sei se o o fix do bug xxx resolve o problema q eu estou tendo.
oh oh

 
Magento Community Magento Community
Magento Community
Magento Community
 
gutogodoy
Jr. Member
 
Total Posts:  18
Joined:  2009-05-15
 

Cesar,

obrigado pela dica, vou tentar para ver se resolvo o problema.

abr

guto

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top