Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Custom Themes Reverting Back To Default
 
GetDirtyMX
Jr. Member
 
Total Posts:  8
Joined:  2009-05-04
 

For some reason, when I use a custom theme, the home page displays using my custom theme just fine.  If I click on any link to a category page (or any other page), the theming reverts back to default/default.

I don’t understand why… it works perfectly on my local server but screws up when I try it on my hosted server with Network Solutions.

Is this a problem with the database?

And to save time, I have cleared the cache (it’s actually disabled during production as advised by documentation), manually deleted files in the cache folders using FTP, cleared cookies, session info, etc.  Still can’t correct the problem.

Please advise.

Michael

 
Magento Community Magento Community
Magento Community
Magento Community
 
NeilA
Moderator
 
Avatar
Total Posts:  1372
Joined:  2007-09-17
Blue Mountains, Oz
 

Under System > Configuration > General > design what do you have under the ‘Themes’ section?

 
Magento Community Magento Community
Magento Community
Magento Community
 
GetDirtyMX
Jr. Member
 
Total Posts:  8
Joined:  2009-05-04
 

I have posted screen shots of both the file structure and the settings from Config-->Design-->Themes

I have also included screen shots of the home page and a category page from the site.  Notice the change back to the default theme with the category page even though it should remain as the “Blue” theme (the header gives it away).

Even if I choose other themes like “Blank” or “GDMX,” the problem still persists.

Upon viewing server logs, I found the following:

Directory index forbidden by Options directive: ...htdocs/store/skin/frontend/default/blue/, referer: http://www.getdirtymx.com/store/

Michael

Image Attachments
design.giffile-structure.gifblue-home.gifapparel-category.gif
 
Magento Community Magento Community
Magento Community
Magento Community
 
NeilA
Moderator
 
Avatar
Total Posts:  1372
Joined:  2007-09-17
Blue Mountains, Oz
 

It sounds like a permissions issue then, on the template folders… I can’t quite see enough in the screenshot to tell.
But I would also put ‘blue’ in the skins and layout area of the first screenshot.(not sure if that’s needed, but having them there doesn’t hurt my store!)

Cheers

 
Magento Community Magento Community
Magento Community
Magento Community
 
GetDirtyMX
Jr. Member
 
Total Posts:  8
Joined:  2009-05-04
 

I can redo the screen shot… what would you like to see?

Michael

 
Magento Community Magento Community
Magento Community
Magento Community
 
NeilA
Moderator
 
Avatar
Total Posts:  1372
Joined:  2007-09-17
Blue Mountains, Oz
 

Just on the second screenshot - the permissions list on the right is cut off… wink
But this maybe something your host needs to fix, depending on the access you have.

Pardon my delayed response… I’ve on holiday (vacation) and just preparing to head back to work, which means a lot less time on the Magento forums…

Cheers

 
Magento Community Magento Community
Magento Community
Magento Community
 
GetDirtyMX
Jr. Member
 
Total Posts:  8
Joined:  2009-05-04
 

here you go… different theme but same problem

Image Attachments
permissions.gif
 
Magento Community Magento Community
Magento Community
Magento Community
 
JLHC
Mentor
 
Avatar
Total Posts:  1287
Joined:  2008-05-09
Tampa, FL
 

Have you change the “Custom Design” under CMS --> Manage Pages to the custom theme?

 
Magento Community Magento Community
Magento Community
Magento Community
 
GetDirtyMX
Jr. Member
 
Total Posts:  8
Joined:  2009-05-04
 

Which pages are you suggesting to change… I don’t see any page there that would affect changes on the category pages.  I tried your suggestion on the home page, and it made no difference on the category or product pages.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top