Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Fatal error: Class ‘Mage_Core_Model_Config_Base’ not found
 
sitmex
Jr. Member
 
Avatar
Total Posts:  9
Joined:  2008-02-28
Guadalajara, Mexico
 

Good Day folks.

I would really try this thing for my store, so I downloaded the latest version 0.817240, stored at (papeleriamaya.com) but I got the following errors:

Warning: include(Mage/Core/Model/Config/Base.php[function.include]failed to open streamNo such file or directory in /home/papeleriamaya/www/www/app/code/core/Mage/Core/functions.php on line 44

Warning
: include() [function.include]Failed opening 'Mage/Core/Model/Config/Base.php' for inclusion (include_path='/home/papeleriamaya/www/www/app/code/local:/home/papeleriamaya/www/www/app/code/community:/home/papeleriamaya/www/www/app/code/core:/home/papeleriamaya/www/www/lib:.:/usr/local/php5/lib/php'in /home/papeleriamaya/www/www/app/code/core/Mage/Core/functions.php on line 44

Fatal error
: Class 'Mage_Core_Model_Config_Base' not found in /home/papeleriamaya/www/www/app/code/core/Mage/Core/Model/Config.php on line 30

I believe all the requirements are met:
from a simple phpinfo:

PHP Version 5.2.5

PDO support    enabled
PDO drivers     sqlite
mysqlsqlite2

mcrypt support    enabled
Version     2.5.7
Api No     20021217
Supported ciphers     cast
-128 gost rijndael-128 twofish arcfour cast-256 loki97 rijndael-192 saferplus wake blowfish-compat   des rijndael-256 serpent xtea blowfish enigma rc2 tripledes
Supported modes     cbc cfb ctr ecb ncfb nofb ofb stream

Simplexml support    enabled
Revision     $Revision
1.151.2.22.2.35 $
Schema support     enabled

DOM
DOM
/XML     enabled
DOM
/XML API Version     20031129
libxml Version     2.6.27
HTML Support     enabled
XPath Support     enabled
XPointer Support     enabled
Schema Support     enabled
RelaxNG Support     enabled

MySQL
MySQL Support    enabled
Active Persistent Links     0
Active Links     0
Client API version     5.0.45
MYSQL_MODULE_TYPE     external
MYSQL_SOCKET     
/tmp/mysql.sock
MYSQL_INCLUDE     
-I/usr/local/mysql5/include/mysql
MYSQL_LIBS     
-L/usr/local/mysql5/lib/mysql -lmysqlclient

Any Ideas on how to go fruter???

TIA for any guidance and help,

Oscar
Guadalajara, Mexico

 
Magento Community Magento Community
Magento Community
Magento Community
 
ptityop
Sr. Member
 
Total Posts:  105
Joined:  2007-11-21
 

you get this on the install ? If so you should set 777 permissions to your app folder i guess… pretty sure this is a permissions issue though

 
Magento Community Magento Community
Magento Community
Magento Community
 
sitmex
Jr. Member
 
Avatar
Total Posts:  9
Joined:  2008-02-28
Guadalajara, Mexico
 

Testing on 775 (that’s what my host is allowing me to, testing....

 
Magento Community Magento Community
Magento Community
Magento Community
 
ptityop
Sr. Member
 
Total Posts:  105
Joined:  2007-11-21
 

if not just set them all up so they are writable… then later on the production one you can change them for better security… but you should be able to go through instal this way

 
Magento Community Magento Community
Magento Community
Magento Community
 
sitmex
Jr. Member
 
Avatar
Total Posts:  9
Joined:  2008-02-28
Guadalajara, Mexico
 
sitmex - 12 March 2008 03:24 PM

Testing on 775 (that’s what my host is allowing me to, testing....

No good.  I’ve changed to 775 attributes but still no luck.

I’m changing my mind on this project.

 
Magento Community Magento Community
Magento Community
Magento Community
 
ptityop
Sr. Member
 
Total Posts:  105
Joined:  2007-11-21
 

have you set all folders and files this way?

 
Magento Community Magento Community
Magento Community
Magento Community
 
ortsaipekim
Jr. Member
 
Total Posts:  18
Joined:  2007-11-07
 

Check index.php - if it there is a line Mage::run(’base’) change it to Mage::run(’default’)

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top