Magento Forum

   
Fatal error: Out of memory (allocated 14680064) (tried to allocate 1245184 bytes) in /home/****/magento/lib/Zend/Date.php on line 2554
 
Buy3DWallpapers.com
Jr. Member
 
Total Posts:  3
Joined:  2009-05-09
 

Hello all,

I keep getting this error message randomly and desperately need to resolve it. There is no consistent point at which this occurs.

I’m on a dedicated windows server running xamp apache and my magento keeps knocking the server over and stopping apache, which is not good as I have several other sites hosted on it.

After reading and reading similar posts on these forums, I have changed all the setting regarding memory allocation in both my php.ini file and in the .htaccess files, or at least I think I have change the correct parts.

I have also read an answer stating this:

“your server system date doesnt match or magento system didnt find the file to read the system date .so while searching the system date unlimited time the maximum allocation space exceeds”

So I changed my magento system time to GMT, berlin as my site is hosted on a 1and1 server based in germany, still no joy :0(

Any help and pointers would be greatly appreciated - Thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
ckosny
Guru
 
Total Posts:  349
Joined:  2009-02-28
Luxembourg
 

Well,what is the memory limit of PHP on your installation? The error message seems to indicate that the limit is set at 14MB which would be way to low. So use e.g. phpinfo to check the settings.

Good luck

Claudia

 
Magento Community Magento Community
Magento Community
Magento Community
 
Incognito
Guru
 
Total Posts:  322
Joined:  2008-08-07
Michigan
 

you should use the .htaccess file that comes with magento

 
Magento Community Magento Community
Magento Community
Magento Community
 
Buy3DWallpapers.com
Jr. Member
 
Total Posts:  3
Joined:  2009-05-09
 

Thank you for your help,

I’ve checked my phpinfo file and it states: memory_limit 300M= 300M

My error message was an old one I think but has reappeared yesterday and I didn’t make a note! I cannot seem to replicate the error now to post the specific memory error.

So, my question is really, is there anything else that can cause this error? Is there any other files that hold the memory limits that I have missed or something with the zend build that may be causing this?

Thanks again and I’m sure I’ll be posting so with the latest error string.

 
Magento Community Magento Community
Magento Community
Magento Community
 
skippybosco
Moderator
 
Avatar
Total Posts:  796
Joined:  2008-10-03
 

There is a possibility that your host does not allow overiding of php values in .htaccess.

You can try creating a php.ini file in the root of your Magento installation that has this in it:

memory_limit 64M

You can also try creating a file called phpinfo.php that has this in it:

<?php
    phpinfo
();
?>

Then browse to it and see what it lists for the memory_limit value

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
    Back to top