Magento Forum

   
Chmod at install
 
accessdev
Jr. Member
 
Total Posts:  2
Joined:  2007-09-03
Montpellier France
 

Hi,

I read the installation post on this forum

does chmod 777 is necessary for install

i run apache as user www-data and my ftp account is under user1:www-data so usually chmod 775 is ok for all
operation from php scripts and ssh / ftp account

anyway i get 404 errors after the install

-http://xxxxxxxxxxxxxxxxxxxxx.com/mg08/checkout/cart/ --> not found
-http://xxxxxxxxxxxxxxxxxxxxx.com/mg08/customer/account/login/ -> not found

i suppose this is a rewrite problem , but i checked use rewrite on install and mod_rewrite is enabled on my server

does using a subdomain (sub.maindomain.com) may causes this problem ?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Michael
Enthusiast
 
Total Posts:  826
Joined:  2007-08-31
 

hi accessdev

chmod 777 is required only to be able to use built-in upgrade tool for users whose files are not owned by apache user or group

i suppose everything should be ok for you with chmod 775

if you prefer upgrading with svn or with regular all-in-one package - just run

chmod 775 app/etc var var/.htaccess && chmod -R 775 media
before installation, as no other folders has to be writable by apache in that case.

can you please post here your .htaccess file the you have under magento root folder ?
did you try to install with no ‘Use URL rewrites’ option checked?

 
Magento Community Magento Community
Magento Community
Magento Community
 
accessdev
Jr. Member
 
Total Posts:  2
Joined:  2007-09-03
Montpellier France
 

I have no root .htacces file, only one in app folder .

I checked “Use URL Rewrite\” at install.

Could you post your so i can see if it that fix the problem

Thanks wink

 
Magento Community Magento Community
Magento Community
Magento Community
 
Michael
Enthusiast
 
Total Posts:  826
Joined:  2007-08-31
 

I guess you are using Mac. Please make sure that Finder displays hidden files before uploading Magento to web-server (Files with a ‘.’ at the start are invisible in the Mac OS finder, so it is likely you will miss this file if you copy the files out of the original folder. You can use the terminal to copy the file to the correct location if you need too)

You can also find the Magento root folder .htaccess file contents below:

############################################
## uncomment these lines for CGI mode
## make sure to specify the correct cgi php binary file name
## it might be /cgi-bin/php-cgi

#Action php5-cgi /cgi-bin/php5-cgi
#AddHandler php5-cgi .php

############################################
## this line is specific for 1and1 hosting

#AddType x-mapp-php5 .php

############################################
## default index file

DirectoryIndex index.php

<IfModule mod_php5.c>

############################################
## adjust memory limit

    
php_value memory_limit 32M
    php_value max_execution_time 18000

############################################
## disable magic quotes for php request vars

    
php_flag magic_quotes_gpc off

############################################
## enable php short tags for templates

    
php_flag short_open_tag on

</IfModule>

<
IfModule mod_ssl.c>

############################################
## make HTTPS env vars available for CGI mode

    
SSLOptions StdEnvVars

</IfModule>

<
IfModule mod_rewrite.c>

############################################
## enable rewrites

    
Options +FollowSymLinks
    RewriteEngine on

############################################
## you can put here your magento root folder path relative to web root

    #RewriteBase /magento/

############################################
## workaround for HTTP authorization in CGI environment

    
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

############################################
## always send 404 on missing files in these folders

    
RewriteCond %{REQUEST_URI} !^/(media|skin|js)/

############################################
## never rewrite for existing files, directories and links

    
RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond 
%{REQUEST_FILENAME} !-d
    RewriteCond 
%{REQUEST_FILENAME} !-l

############################################
## rewrite everything else to index.php

    
RewriteRule .* index.php [L]

</IfModule>


############################################
## Prevent character encoding issues from server overrides
## If you still have problems, use the second line instead

AddDefaultCharset Off
#AddDefaultCharset UTF-8
Order allow,deny
Allow from all

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
    Back to top