Magento Forum

Upgrade to version -0.8.17240 -error
 
srinigenie
Guru
 
Avatar
Total Posts:  539
Joined:  2008-02-04
 

Hi,

I downloaded the latest version of magento and overwrote the files of previous version. I cleared the cache in admin before upgrading. Now after upgrading I get these errors:

On trying to acces Admin using :
http://localhost/magento/admin
exception ‘Mage_Core_Exception’ with message ‘Invalid store requested: “admin”.’ in D:\wamp\www\magento\app\Mage.php:356
Stack trace:
#0 D:\wamp\www\magento\app\code\core\Mage\Core\Model\App.php(494): Mage::throwException(’Invalid store r...’)
#1 D:\wamp\www\magento\app\code\core\Mage\Core\Model\Url.php(215): Mage_Core_Model_App->getStore(NULL)
#2 D:\wamp\www\magento\app\code\core\Mage\Core\Model\Url.php(101): Mage_Core_Model_Url->setStore(NULL)

On accessing the store home page:

Strict Notice: Declaration of Mage_Eav_Model_Entity_Abstractold::_insertAttribute() should be compatible with that of Mage_Eav_Model_Entity_Abstract::_insertAttribute() in D:\wamp\www\magento\app\code\core\Mage\Eav\Model\Entity\Abstractold.php on line 28
[0] in include("D:\wamp\www\magento\app\code\core\Mage\Eav\Model\Entity\Abstractold.php") in D:\wamp\www\magento\app\code\core\Mage\Core\functions.php on line 44
[1] in __autoload("Mage_Eav_Model_Entity_Abstractold") in D:\wamp\www\magento\app\code\core\Mage\Catalog\Model\Entity\Abstract.php on line 27

Also I checked the demo store and in the admin products page, I wasnt able to locate the prices tab? Has that been relocated to new place?

Thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
srinigenie
Guru
 
Avatar
Total Posts:  539
Joined:  2008-02-04
 

Am running this on WAMP and upgrading from version 0.8.16100. The previous version used to work just fine and even when revert back to the previous version I donot face the above issues.

 
Magento Community Magento Community
Magento Community
Magento Community
 
seDev
Member
 
Total Posts:  51
Joined:  2008-01-22
 

Hi srinigenie,

I had a similar error after upgrading and it was related to the index.php file in the main installation directory. The default store used to be called “base” but now it is called “default”. Go figure!

Anyway, you might check your index.php file. Line 29:
Mage::run(’default’);

Hope that helps,

Séamus

 
Magento Community Magento Community
Magento Community
Magento Community
 
Michae1
Enthusiast
 
Total Posts:  826
Joined:  2007-08-31
 

Hi srinigenie,

Can you please make sure that you ovewritten all the old files ? E.g. there is no Mage_Eav_Model_Entity_Abstractold class in the new version.

 
Magento Community Magento Community
Magento Community
Magento Community
 
srinigenie
Guru
 
Avatar
Total Posts:  539
Joined:  2008-02-04
 

Thanks for the inputs. Maybe somefiles were not overwritten when I extracted the zip file. Backed up the entire stuff, deleted the entire code (not the database). Extracted the new version of magento. Placed local.xml in app/etc directory and everything worked fine smile

 
Magento Community Magento Community
Magento Community
Magento Community
 
lorenzo01
Sr. Member
 
Avatar
Total Posts:  221
Joined:  2007-09-06
France
 

what is the difference between Mage::run(’default’); and Mage::run(’base’); in the index.php ??

 
Magento Community Magento Community
Magento Community
Magento Community
 
Moshe
Magento Team
 
Avatar
Total Posts:  1770
Joined:  2007-08-07
Los Angeles
 

@lorenzo01: it specifies the default store code for this index.php location.

Before the default store was called ‘base’, in new release it’s called ‘default’

 
Magento Community Magento Community
Magento Community
Magento Community
 
ashanholt
Member
 
Avatar
Total Posts:  33
Joined:  2007-09-05
 

seDev - thank you, that post saved me tons of time!

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top