Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Custom Blocks not working in Category view.phtml
 
Jaxbulls
Jr. Member
 
Total Posts:  17
Joined:  2007-08-31
 

So I made a custom block that I need to display on my category list pages.
It needs to be below the category title but above the category list.

This is my block

<block type="catalog/navigation" name="subnav" as="subnav" template="catalog/category/view/subnav.phtml"/>

If I put that in my page.xml and link it with the following code in 2columns-right.phtml

<?php echo $this->getChildHtml('subnav'?>
it shows up on the page...albeit not in the right spot.

So i realized it needs to be in my category view.phtml file.
But no matter what I do in that view.phtml file and my catalog.xml file, I cannot get anything from my block to show up on my category pages.

Can anyone help?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Jaxbulls
Jr. Member
 
Total Posts:  17
Joined:  2007-08-31
 

2 days later and still having this same problem.

 
Magento Community Magento Community
Magento Community
Magento Community
 
supportfree
Jr. Member
 
Total Posts:  8
Joined:  2009-05-23
 

I use this: http://demo.hello-magento.com/freecms/electronics.html
--

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top