Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Problem Adding New Product
 
evdat
Member
 
Avatar
Total Posts:  35
Joined:  2008-02-28
Carthage, MO
 

I got Magento installed, and I was able to place new orders, and setup new customers, but when I tried to go in and add new products I get an error.

Unable to create directory ‘/var/www/virtual/xxxxxxxx/htdocs/media/catalog/product/’.

I checked the permissions on /media/ and they were 777 fully world writable. So I then thought well… maybe if I help it out a bit, so I created the catalog and product directories underneath and made sure they had the permissions of 777 as well.

mjohnson@node1:/var/www_local/virtual/xxxxxxxx/htdocs/media/catalog/product$ ls -la
total 8
drwxrwxrwx 2 mjohnson mjohnson 4096 2008-03-06 23:18 .
drwxrwxrwx 3 mjohnson mjohnson 4096 2008-03-06 23:18 ..

It still gives me the error though, and I can’t add any new products.

I’ve filled in all the required fields including the “Small Image”. The image I’m uploading is only 4k.
I checked the Apache error log, and didn’t see anything there relating to my request.

Does anyone have any suggestions of where to start looking to diagnose this?
Are there some logs somewhere that might have more details?

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top