Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email

Magento Forum

Magento Connect Trouble
Jr. Member
Total Posts:  1
Joined:  2009-05-04


I intalled Magento on my website, I can run my backend perfectly but when I try to run Magento Connect i get this:

Error: Please check for sufficient write file permissions

Your Magento folder does not have sufficient write permissions, which this web based downloader requires.

If you wish to proceed downloading Magento packages online, please set all Magento folders to have writable permission for the web server user (example: apache) and press the “Refresh” button to try again.

I´ve checked all permissions and they are ok...don´t know what to do....any guess?

Magento Community Magento Community
Magento Community
Magento Community
Total Posts:  1158
Joined:  2008-04-24

Well, that warning tells you the permissions are not okay. Are you on a shared server? In case PHP is handled in DSO mode (Apache module), you need to make virtually every directory and file in your Magento installation world writable in order to use Magento Connect. This is because the web server needs to be able to write to your files. This is potentially a big security risk as also other users on the server will be able to overwrite/delete your files.

If you still want to use Magento Connect, you should change the permissions on every directory in your install (including the Magento root directory) to 777. Files should be 666 to be writable. At least, then the error message should go away.

Again, I do not recommend such permission settings on a production store. If you have SSH access, you can use PEAR to upgrade or install extensions.

If PHP scripts are executed under the script owner (e.g. suEXEC/suPHP), permissions of 755 for directories and 644 for files should work.

Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top