Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Checkout problem
 
James Ball
Member
 
Total Posts:  46
Joined:  2009-01-27
 

I have had several phone calls from customers who are able to add products to there basket but when trying to checkout on the one page checkout screem get redirected to the home page or “your basket is empty” page and therefore unable to place an order.
This is obviously a seriouse problem for me as i have no idea how many sales i am loosing.

Is this a know problem?

What would you recomend that i do about it?

my website is www.thesuncareshop.com

would a few people mind testing it for me to see if they can get to step 2 of the checkout please.

 
Magento Community Magento Community
Magento Community
Magento Community
 
bydand
Jr. Member
 
Total Posts:  11
Joined:  2009-03-08
 

Hi,

I’ve just gone through to step 5 of the checkout and it seems to be working ok for me.

I am currently building my Magento store, but have an existing one with Cubecart and I’m getting exactly the same calls from customers that you’re getting. It only happens randomly though, so I’m not sure if it has something to do with the browser they’re using or an issue with the ssl certificate.

Goodluck in sorting it out, but it’s definitley working for me at the moment, I’m based in Australia

Cathy

 
Magento Community Magento Community
Magento Community
Magento Community
 
James Ball
Member
 
Total Posts:  46
Joined:  2009-01-27
 

First of all thanks for your test.

As you say i think it is due to the browser, i spoke directly to 2 of the customers and they informed me there computer was old (that was about the most technical information as i could get out of them) i will try to find out more if i get feed back from other customers.

Even though it may be only a small % or browsers its still lost order and therefore lost profit so i think it is a seriouse issue.

If any one has any other thoughts please let me know.

One thing i did which helps was to add extra text to the “your shopping cart is empty page” saying something like we are awaer of some problems please call us etc…

 
Magento Community Magento Community
Magento Community
Magento Community
 
J_T_
Mentor
 
Avatar
Total Posts:  1961
Joined:  2008-08-07
London-ish, UK
 

Can also be their ISP using proxies and hence your session validation throwing them out. Use Google Analytics segregation reports to see whether you can narrow it down by ISP or Browser version. Turning off session validation has helped others remedy similar situations.

 
Magento Community Magento Community
Magento Community
Magento Community
 
EmJaInteractive
Sr. Member
 
Avatar
Total Posts:  121
Joined:  2009-04-29
Charlotte, NC USA
 

Any more issues on this? I have two customers contact me with same issues in a site I just released 2 days ago.

I spoke to one and they are using Windows XP with IE.

They have exact same problem, add items to cart fine, they “proceed to checkout” and they lose the contents of their cart and redirects to home page.

Now my web site is http: and when they press “proceed to checkout” it goes to https:

Would this cause any potential problems?

Any insight would be great! I can not replicate it, but if 2 reports in 24 hours of exact same issue there has to be something wrong.

 
Magento Community Magento Community
Magento Community
Magento Community
 
James Ball
Member
 
Total Posts:  46
Joined:  2009-01-27
 

Had another customer call up this morning… who know how many customers are being lost!

My basket page is also http: and then the check out https: maybe the problem is to do with this.

solving this is my top priority so i will hopefuly find something out ant let you know.

If any one has any further problems with this or if anyone can pinpoint either a browser/opperating system or provider please let me know.

I will turn off session validation and see if i still get problems. Could you let me know if there is any problems associated with turniong off session validation (or what it does?)

James

 
Magento Community Magento Community
Magento Community
Magento Community
 
James Ball
Member
 
Total Posts:  46
Joined:  2009-01-27
 

By the way in order to turn session validation off go to /System/configeration/Web in you admin panel and turn all session validation settings to NO, i read that you maybe should leave the Validate HTTP_USER_AGENT to YES but i dont know why so i changed it to NO and have had no problems as yet.

 
Magento Community Magento Community
Magento Community
Magento Community
 
EmJaInteractive
Sr. Member
 
Avatar
Total Posts:  121
Joined:  2009-04-29
Charlotte, NC USA
 

One of my customers was able to help me test it and they had a AT&T;Browser, the article I read said to leave the LAST validation to YES. I simply changed this to NO and had them try again. It worked fine for them and have no complaints since.

So change all Validation to NO.

 
Magento Community Magento Community
Magento Community
Magento Community
 
gronnies
Jr. Member
 
Total Posts:  8
Joined:  2010-01-11
 

Hello,

I’ve been having the same problems and was wondering if after all this time, if the problem still exists for you?  Was it fixed by changing all the validations to NO?

Thanks a lot!

 
Magento Community Magento Community
Magento Community
Magento Community
 
James Ball
Member
 
Total Posts:  46
Joined:  2009-01-27
 

problem still exists, customers regularly phone up saying that they get redirected to the basket or home page when clicking the confirm buttom at the payment stage of the checkout.

 
Magento Community Magento Community
Magento Community
Magento Community
 
James Ball
Member
 
Total Posts:  46
Joined:  2009-01-27
 

i just checked and i still had the last validation set to yes i have now changed this to no we will see ywhat happens

 
Magento Community Magento Community
Magento Community
Magento Community
 
gronnies
Jr. Member
 
Total Posts:  8
Joined:  2010-01-11
 

Thank you for responding ... I changed mine to NO and will let you know as well if it is working for me too.

 
Magento Community Magento Community
Magento Community
Magento Community
 
gronnies
Jr. Member
 
Total Posts:  8
Joined:  2010-01-11
 

Ughh, another lost order.  Guess it didn’t help.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top