Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

How do I enable secure checkout? 
 
Chris Williams
Member
 
Avatar
Total Posts:  67
Joined:  2007-09-02
Dallas, TX
 

Now that I’ve got SSL ready, where do I set that for the One Page checkout?

Magento ver. 0.8.16100

 
Magento Community Magento Community
Magento Community
Magento Community
 
Chris Williams
Member
 
Avatar
Total Posts:  67
Joined:  2007-09-02
Dallas, TX
 

I’m bumping this, because really need some help getting to the secure checkout page.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Michael_1
Enthusiast
 
Total Posts:  826
Joined:  2007-08-31
 

Hi Chris,

Please go to admin System -> Configuration -> Web -> Secure -> change ‘Use Secure URLs in Frontend’ to ‘Yes’ and Save Config.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Chris Williams
Member
 
Avatar
Total Posts:  67
Joined:  2007-09-02
Dallas, TX
 

Hi Michael,

I figured it had to be something like that.  I’ve already set that value, but the checkout doesn’t go to the secure site.  I’ve attached the screen of those settings.

Is there anywhere else I should check?

Image Attachments
Picture 1.png
 
Magento Community Magento Community
Magento Community
Magento Community
 
Michael_1
Enthusiast
 
Total Posts:  826
Joined:  2007-08-31
 

On the screenshot Base URL field has {{base_url}}, that means that Magento will use the same URL as in Unsecure section.
You should put here instead of {{base_url}} the real value, e.g. https://your.domain.com/magento/

Please let me know if it helps. If it doesn’t, please PM me the URLs (both secure and unsecure) of your Magento installation and we will figure it out.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Chris Williams
Member
 
Avatar
Total Posts:  67
Joined:  2007-09-02
Dallas, TX
 

That was it!  Thank you very much.

 
Magento Community Magento Community
Magento Community
Magento Community
 
redhotrobbie
Jr. Member
 
Total Posts:  27
Joined:  2008-10-27
 

After I made the change to use secure on front pages, the whole admin section stopped being able to write to the database, and any updates say they worked, but diddnt.  Whats the issue?

 
Magento Community Magento Community
Magento Community
Magento Community
 
oztrack
Jr. Member
 
Total Posts:  3
Joined:  2008-12-06
 

How do i make my site go to and stay at https://domain.com instead of https://www.domain.com. My certificate is only for domain.com not http://www.domain.com

 
Magento Community Magento Community
Magento Community
Magento Community
 
hydra
Guru
 
Avatar
Total Posts:  378
Joined:  2008-08-26
Amsterdam
 

You should change the secure {{base_url}} to https://domain.com.

 
Magento Community Magento Community
Magento Community
Magento Community
 
centtaco
Member
 
Total Posts:  55
Joined:  2009-05-12
 

Awesome! Just what I needed.

 
Magento Community Magento Community
Magento Community
Magento Community
 
info328
Jr. Member
 
Total Posts:  4
Joined:  2011-02-13
 
redhotrobbie - 04 December 2008 06:29 AM

After I made the change to use secure on front pages, the whole admin section stopped being able to write to the database, and any updates say they worked, but diddnt.  Whats the issue?

Had the same problem, It seems like magento could create a loop if you have rewrites in htaccess. What I did is change rewrite engines to “off” in htacces then went into magento, change settings back and change htaccess file back.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top