Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

ISPConfig 3, Fast-CGI, SuEXEC - Admin login not working
 
doughold
Jr. Member
 
Total Posts:  12
Joined:  2009-04-03
 

I keep getting a 500 internal error when trying to log in to a fresh install of Magento. I get the following in the error log:

[Wed Apr 22 16:04:43 2009] [warn] mod_fcgidread data timeout in 40 seconds
[Wed Apr 22 16
:04:43 2009] [error] [client .........] Premature end of script headersindex.php

This only happens once the user is authenticated, before that I can browse to the /admin section and get the login and password boxes.

I used the SSH installation script to install Magento. What would be causing this error to be thrown?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Gig
Jr. Member
 
Total Posts:  1
Joined:  2007-11-19
 

to get magento running under suexec:

chmod 755 js
chmod 644 js/index.php
chmod 755 index.php
chmod 755 app
chmod 644 app/Mage.php
chmod 755 downloader
chmod 644 downloader/index.php

admin pages weren’t working for me after upgrade as i forgot to chmod the js/index.php file
magento connect page wasn’t working after upgrade as i forgot to change downloader/index.php

regards

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top