Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Produkte werden im Warenkorb nicht angezeigt - bitte dringend um Hilfe! 
 
mistersmoke
Jr. Member
 
Total Posts:  2
Joined:  2013-04-08
 

Hallo,

ich habe bei meinem Magento-Shop das Problem, dass wenn man ein Produkt hinzufügt, das Produkt zwar links im Warenkorb angezeigt wird, wenn man den Warenkorb allerdings aufruft, erscheint die Warenkorbseite ohne jegliche Produkte.
Hat einer eine Idee ? Die Kunden ärgert es auch schon. Der Bestellvorgang an sich klappt, nur das Aufrufen des Warenkorbes nicht.

Ich denke er bricht hier ab :

<div class="cart">
<div class="page-title title-buttons">
<h1>Warenkorb</h1>
<ul class="checkout-types">

Es sieht also nach einem Error bei den checkout-types aus.

Hat einer eine Idee ? Ich verzweifel solangsam.

Vielen Dank und Beste Grüße

 
Magento Community Magento Community
Magento Community
Magento Community
 
Siggi_Schmitz
Enthusiast
 
Avatar
Total Posts:  811
Joined:  2011-07-03
 

Schalt mal unter System / Konfiguration / Entwickleroptionen das logging ein.
Dann schau mal ob du Fehler in Dateien innerhalb von var/log/ siehst.

 
Magento Community Magento Community
Magento Community
Magento Community
 
mistersmoke
Jr. Member
 
Total Posts:  2
Joined:  2013-04-08
 

Hey,

vielen Dank für deine Antwort. Also in der Log steht dann :

2013-05-27T13:04:58+00:00 ERR (3): Notice: Undefined index: items in /var/www/vhosts/virginia-electric.de/httpdocs/app/code/local/Magentothem/Bestsellerproductvertscroller/Block/Bestsellerproductvertscroller.php on line 37
2013-05-27T13:04:58+00:00 ERR (3): Notice: Undefined index: items in /var/www/vhosts/virginia-electric.de/httpdocs/app/code/local/Magentothem/Bestsellerproductvertscroller/Block/Bestsellerproductvertscroller.php on line 37
2013-05-27T13:05:03+00:00 ERR (3): Notice: Use of undefined constant MCRYPT_BLOWFISH - assumed ‘MCRYPT_BLOWFISH’ in /var/www/vhosts/virginia-electric.de/httpdocs/lib/Varien/Crypt/Mcrypt.php on line 56
2013-05-27T13:05:03+00:00 ERR (3): Notice: Use of undefined constant MCRYPT_MODE_ECB - assumed ‘MCRYPT_MODE_ECB’ in /var/www/vhosts/virginia-electric.de/httpdocs/lib/Varien/Crypt/Mcrypt.php on line 60
2013-05-27T13:05:46+00:00 ERR (3): Notice: Use of undefined constant MCRYPT_BLOWFISH - assumed ‘MCRYPT_BLOWFISH’ in /var/www/vhosts/virginia-electric.de/httpdocs/lib/Varien/Crypt/Mcrypt.php on line 56
2013-05-27T13:05:46+00:00 ERR (3): Notice: Use of undefined constant MCRYPT_MODE_ECB - assumed ‘MCRYPT_MODE_ECB’ in /var/www/vhosts/virginia-electric.de/httpdocs/lib/Varien/Crypt/Mcrypt.php on line 60
2013-05-27T13:05:52+00:00 ERR (3): Notice: Use of undefined constant MCRYPT_BLOWFISH - assumed ‘MCRYPT_BLOWFISH’ in /var/www/vhosts/virginia-electric.de/httpdocs/lib/Varien/Crypt/Mcrypt.php on line 56
2013-05-27T13:05:52+00:00 ERR (3): Notice: Use of undefined constant MCRYPT_MODE_ECB - assumed ‘MCRYPT_MODE_ECB’ in /var/www/vhosts/virginia-electric.de/httpdocs/lib/Varien/Crypt/Mcrypt.php on line 60

Hilft dir das irgendwie weiter ? Also es scheint ja so, als ob es gewisse crypt methoden nicht gibt oder?

Beste Grüße

 
Magento Community Magento Community
Magento Community
Magento Community
 
Siggi_Schmitz
Enthusiast
 
Avatar
Total Posts:  811
Joined:  2011-07-03
 

Hi,

benutzt du ein eigenes / erworbenes Theme? Wenn ja, stell mal wieder auf default um, cache löschen und testen.
Ansonsten deaktiviere mal das Modul Bestsellerproductvertscroller, ich weiß ja nicht was genau das Modul macht aber auf jeden Fall ist es unsauber (siehe logs), vielleicht greift das ja auch auf der Warenkorb-Seite zu, also verschieb mal die Konfigurationsdatei des Moduls (ist ne XML - Datei in app/etc/modules, einfach in irgend nen anderen Ordner verschieben, dann cache löschen).

Wegen den anderen Fehler, dir fehlt anscheinend die php mcrypt extension. Einfach mal googeln wie man die installiert.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top