Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Flat Catalog is turned of - still complaining about limit of 64
 
Futuros
Jr. Member
 
Total Posts:  6
Joined:  2009-03-31
 

I have my flat catalog on No.

But when i want to add a new attribute it is saying i allready have 65 filtarable attributes.
It shouldn’t matter because i don’t need a flat catalog and therefore have it turned off.

Why is it still complaining?

I also thought it was odd it was allready complaining because i dont have that many attributes.
after some research i learned that every attribute which has either ‘is_filterable’ OR ‘is_filterable_in_search’ OR ‘used_for_sort_by’ set to >1 gets an index in the flat catalog table.

I did a select on my `inpt_eav_attribute` table

SELECT FROM `inpt_eav_attributeWHERE `entity_type_id`=AND `is_filterable_in_search`=AND `is_filterable`!=1

It returned 46 rows. All non user defined attributes.

Attributes like ‘news_from_date’ are set to be filterable_in_search while it isnt even off the type dropdown, multipleselect etc.

My second question:
Why do these attributes have is_filterable_in_search set to 1?
Did something mess up my table or is this default?
Can i change these values to 1 for most attributes without breaking something?

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top