Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

fejl ved oprettelse af produkt
 
hjensen
Jr. Member
 
Total Posts:  11
Joined:  2009-04-07
 

Jeg får følgende fejl meddelelse ved oprettelse af produkt :

Fatal error: Call to a member function setProduct() on a non-object in /home/www/sevenparts.dk/magento/app/code/core/Mage/Catalog/Model/Product/Type.php on line 75

Hvad skyldes det ??

 
Magento Community Magento Community
Magento Community
Magento Community
 
powerhosting.dk
Guru
 
Avatar
Total Posts:  549
Joined:  2008-10-20
 
hjensen - 16 April 2009 07:42 AM

Jeg får følgende fejl meddelelse ved oprettelse af produkt :

Fatal error: Call to a member function setProduct() on a non-object in /home/www/sevenparts.dk/magento/app/code/core/Mage/Catalog/Model/Product/Type.php on line 75

Hvad skyldes det ??

Kunne godt skyldes manglende filer eller måske forkerte rettigheder. Hvad siger dine log-filer? især din php-errorlog ?

 
Magento Community Magento Community
Magento Community
Magento Community
 
hjensen
Jr. Member
 
Total Posts:  11
Joined:  2009-04-07
 

Powerhosting
hvor ser jeg log filerne henne ?

 
Magento Community Magento Community
Magento Community
Magento Community
 
powerhosting.dk
Guru
 
Avatar
Total Posts:  549
Joined:  2008-10-20
 
hjensen - 16 April 2009 11:19 AM

Powerhosting
hvor ser jeg log filerne henne ?

Hej igen Hjensen.

PÃ¥ vores magentohoteller ligger alle dine log-filer i /logs i dit homedir.

Jeg kan ikke svare for kollegernes setups desværre, men det kan dit webhotels support helt sikkert. -Der skulle ikke være noget i vejen for at de kan finde dine log-filer frem.

God vind med shoppen og god weekend når du kommer så langt grin

 
Magento Community Magento Community
Magento Community
Magento Community
 
activevps.dk
Member
 
Avatar
Total Posts:  66
Joined:  2009-01-29
Denmark
 

@hjensen: Se om din host kan give dig adgang til log filerne, ellers mÃ¥ du prøve og gen-installerer din Magento shop.  Bruger du den nyeste version af Magento (1.3.0)?

 
Magento Community Magento Community
Magento Community
Magento Community
 
hjensen
Jr. Member
 
Total Posts:  11
Joined:  2009-04-07
 

activevps.dk
ja jeg bruger den nyeste version af Magento 1.3.0

Der hvor det gÃ¥r galt, er nÃ¥r jeg gennem under fanen “prices” ved oprettelsen af nyt produkt. SÃ¥ kommer den fejl meddelelse jeg skrev før.
Samtidig stÃ¥r der en gul advarselstrekant ud for “prices” pÃ¥ selve fanen med teksten:

Denne fane indeholder ugyldige data. Ret venligst problemet før du gemmer.

Og denne advarselstrekant er der uanset om jeg udfylder de krævede felter eller ej.......

Noget der kan forklare fejlen ??

Vil se om jeg kan fÃ¥ adgang til de logfiler, kan nemlig ikke se dem i mit homedir…

 
Magento Community Magento Community
Magento Community
Magento Community
 
hjensen
Jr. Member
 
Total Posts:  11
Joined:  2009-04-07
 

har lagt mærke til at fejl meddelelsen kommer nÃ¥r jeg skal gemme noget under hvilken som helst fane under produktinformation…

Men det ser ud til at jeg dog får gemt noget, men vil gerne være den fejlmeddelelse foruden, aner jo ikke om den får gemt noget forkert....

 
Magento Community Magento Community
Magento Community
Magento Community
 
hjensen
Jr. Member
 
Total Posts:  11
Joined:  2009-04-07
 

har nu set de log filer, og de fortæller ikke noget jeg kan bruge til noget…

Det eneste jeg lige kan komme i tanke om at jeg har lavet om på, er at jeg i .htaccess har skrevet følgende:
Redirect /index.html http://sevenparts.dk/magento/

Kan det være der problemet ligger ??

 
Magento Community Magento Community
Magento Community
Magento Community
 
powerhosting.dk
Guru
 
Avatar
Total Posts:  549
Joined:  2008-10-20
 
hjensen - 18 April 2009 10:30 AM

har nu set de log filer, og de fortæller ikke noget jeg kan bruge til noget…

Det eneste jeg lige kan komme i tanke om at jeg har lavet om på, er at jeg i .htaccess har skrevet følgende:
Redirect /index.html http://sevenparts.dk/magento/

Kan det være der problemet ligger ??

Består fejlen hvis du fjerner det redirect ?

 
Magento Community Magento Community
Magento Community
Magento Community
 
hjensen
Jr. Member
 
Total Posts:  11
Joined:  2009-04-07
 

Nu har jeg installeret Magento igen, og foreløbig ser det ud til at fejlen ved oprettelse af produkt er væk. Har dog ikke installeret oversættelsen til dansk endnu.

Men nu kan jeg ikke huske hvordan man opretter en kategori så den kan ses i forside menuen.
Har prøvet at oprette den som både root category og som subcategory men den bliver ikke vist på forsiden ??
Fik det ellers til at virke i den første installation....
Er der noget jeg mangler at gøre....??

 
Magento Community Magento Community
Magento Community
Magento Community
 
activevps.dk
Member
 
Avatar
Total Posts:  66
Joined:  2009-01-29
Denmark
 

Har du prøvet at flush din cache i Magento admin?

 
Magento Community Magento Community
Magento Community
Magento Community
 
powerhosting.dk
Guru
 
Avatar
Total Posts:  549
Joined:  2008-10-20
 
hjensen - 20 April 2009 09:37 AM

Nu har jeg installeret Magento igen, og foreløbig ser det ud til at fejlen ved oprettelse af produkt er væk. Har dog ikke installeret oversættelsen til dansk endnu.

Men nu kan jeg ikke huske hvordan man opretter en kategori så den kan ses i forside menuen.
Har prøvet at oprette den som både root category og som subcategory men den bliver ikke vist på forsiden ??
Fik det ellers til at virke i den første installation....
Er der noget jeg mangler at gøre....??

Har du aktiveret din root-category for det aktuelle store-view ?

Backend > System > Administrér forretninger > Main Store > Rod-kategori

 
Magento Community Magento Community
Magento Community
Magento Community
 
hjensen
Jr. Member
 
Total Posts:  11
Joined:  2009-04-07
 

powerhosting

under store information har jeg givet den et navn under name, men under store view var status sat til enabled i forvejen....

Men det virker nu, kan bare ikke forstå at når den nu var sat til enabled at det så ikke virkede i forvejen ?

Eller er det det, at man laver save store, der aktiverer den ??

Bar sÃ¥ jeg ved det en anden gang… kan man iøvrigt læse om dette nogen steder ??

 
Magento Community Magento Community
Magento Community
Magento Community
 
hjensen
Jr. Member
 
Total Posts:  11
Joined:  2009-04-07
 

ja kunne godt tænke mig at vide om man kan læse i en eller anden vejledning om hvordan man aktiverer kategorierne ?

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top