Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Admin Buttons suddenly stopped working
 
milspec
Jr. Member
 
Total Posts:  4
Joined:  2009-04-15
 

One second I was using my admin system fine, and the next nothing will work.  I reloaded and it defaults tot he dashboard where certain buttons there work, but if you mouseover any other part of the admin page nothing happens.  You can’t click or anything.

I have reloaded, loged out, cleared cache, everything.  It’s as if the links have gone dead.  What’s happening?

 
Magento Community Magento Community
Magento Community
Magento Community
 
zenironman
Jr. Member
 
Total Posts:  2
Joined:  2008-04-18
 

I am having the same problem. The first two buttons on my admin screen work, and the rest do nothing.

 
Magento Community Magento Community
Magento Community
Magento Community
 
armann
Jr. Member
 
Total Posts:  2
Joined:  2009-04-16
 

I’m also having admin troubles.  Some things seem to work but not others.  My big problem is that under “manage categories” the page is in a constant state of loading.  It never finishes, so I can’t do anything with categories.  Anyone know what the problem is?

Thanks!

 
Magento Community Magento Community
Magento Community
Magento Community
 
milspec
Jr. Member
 
Total Posts:  4
Joined:  2009-04-15
 

I talked to my ISP and they told me that there is an issue with Magento where it overwrites its own permissions and that that’s the problem.  They went in and reset all the permissions for the whole directory and it all went back to normal.

 
Magento Community Magento Community
Magento Community
Magento Community
 
hcpunk
Jr. Member
 
Total Posts:  24
Joined:  2009-04-06
 

Ahh, yep, beaten by mere minutes. This is a common problem when upgrading Magento due to resetting file permissions. If you have fussy hosting this can prevent your site from working correctly.

 
Magento Community Magento Community
Magento Community
Magento Community
 
emeraldco
Jr. Member
 
Avatar
Total Posts:  29
Joined:  2009-02-21
 

This permission thing seems to be a MAJOR problem with this package.  I had the same thing happen.  I changed some permission to 755 and it fixed the buttons, now they animate, but when you click you still get nothing.  Maybe they can use html or php for the back, not so much dependence on java.

 
Magento Community Magento Community
Magento Community
Magento Community
 
HeLiNuT
Jr. Member
 
Total Posts:  4
Joined:  2009-04-17
 

Well not only 1 day into the install and I’ve experienced the same issue, when updating the catergory’s.

On first impressions of this software its looks great however, its dependance in java is way too high. Someone I suspect got carried away with the assumption that Java is god and not though through the loading on browsers and pontential connection issues. The Dashboard as Java seraching the the system fine to a degree but actual critical changes of updating inserting etc should in my view java should be left in its box.

Now to find out how to fix it - bar a full re-install

 
Magento Community Magento Community
Magento Community
Magento Community
 
emeraldco
Jr. Member
 
Avatar
Total Posts:  29
Joined:  2009-02-21
 

Ok even when I did delete all the files it would not really delete it all.  So I uploaded Magento again to a fresh directory, then ran the install and connected it to the same database.  It fixed it.  Later on it stopped working again.  See the problem is that on systems with high security all folders need to be 755 and files need to be 644.  But on some lower security systems they need to be 777 and 666.  So there are a few places in the code where Magento changes it to 777 or 666 and it breaks the system for us folks who use the high security settings from our hosting company. 

I got it all working now when it comes to this.  I have other bugs that I just don’t understand right now…

 
Magento Community Magento Community
Magento Community
Magento Community
 
HeLiNuT
Jr. Member
 
Total Posts:  4
Joined:  2009-04-17
 

I did a full re-install in the end - was easier - will look more into the system later this week. 

I’m keen to understand the coding and skin workings as this is where I work best..

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top