Magento Forum

Category banner on the top. 
 
sholle
Jr. Member
 
Avatar
Total Posts:  25
Joined:  2011-01-05
Serbia
 

Hello everyone,

I have a problems for changing position of category banner.
Used solution from this posts(http://www.magentocommerce.com/boards/viewthread/224094/), but still no luck.

Files for changing is created:

- cat-pic in catalog/category folder with the same code,
- added code in 2columns-left for a new block,
- added code in catalog.xml.

Strange thing is when I add this code in local.xml

<reference name="newreference">
            <
block type="core/template" name="newreferenceblock" as="newreferenceblock" template="catalog/category/newreference.phtm" />
        </
reference>

it will show the content from newreference.phtml file, but when I replace

<reference name="newreference">
            <
block type="catalog/category_view" name="newreferenceblock" as="newreferenceblock" template="catalog/category/newreference.phtml" />
        </
reference>

it will show nothing.

I am using Magento 1.7.0.2
Any ideas please?

Thanks.

 
Magento Community Magento Community
Magento Community
Magento Community
 
sholle
Jr. Member
 
Avatar
Total Posts:  25
Joined:  2011-01-05
Serbia
 

Any solutions or ideas?

 
Magento Community Magento Community
Magento Community
Magento Community
 
indpurvesh
Jr. Member
 
Avatar
Total Posts:  9
Joined:  2009-08-18
 

If you want to override the

catalog/category/view.phtml

Then try this code ...

<reference name="category.products">
            <
block type="catalog/category_view" template="catalog/category/newreference.phtml" />
<
reference>
 
Magento Community Magento Community
Magento Community
Magento Community
 
sholle
Jr. Member
 
Avatar
Total Posts:  25
Joined:  2011-01-05
Serbia
 

Thank you Monty and indpurvesh.

Actually, problem is when I add this in page.xml

<block type="catalog/category_view" name="category.name" template="catalog/category/cat_name.phtml" />

it will work and banner will show. But home page and other CMS pages show an error in View.php core file.

When I add the same code with reference in catalog.xml in <catalog_category_default> it will show nothing and div is empty.

Maybe I put reference code in wrong position, I am not sure.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top