Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 3 of 3
All products “Out of Stock” in Grid View
 
tsunami
Jr. Member
 
Total Posts:  26
Joined:  2010-02-20
 

I submitted this as a bug about a week ago.
http://www.magentocommerce.com/bug-tracking/issue?issue=8502

It is listed as “Assigned” so I assume they are working on it.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Nicro
Jr. Member
 
Total Posts:  10
Joined:  2010-01-07
 

I got the same issue with Magento 1.4.0.1.

See also http://www.magentocommerce.com/boards/viewthread/96053/

 
Magento Community Magento Community
Magento Community
Magento Community
 
Magento4me
Member
 
Avatar
Total Posts:  39
Joined:  2008-04-01
Amsterdam, The Netherlands
 

For me, this was the solution (credits go to Unirgy):

For Magento 1.3.x run this query:

UPDATE eav_attribute SET used_in_product_listing=1 WHERE entity_type_id IN (SELECT entity_type_id FROM eav_entity_type WHERE entity_type_code=\'catalog_product\') AND attribute_code IN (\'name\'\'description\'\'short_description\'\'price\'\'special_price\'\'special_from_date\'\'special_to_date\'\'image\'\'small_image\'\'thumbnail\'\'status\'\'tax_class_id\'\'url_key\'\'required_options\'\'price_type\'\'weight_type\'\'price_view\'\'shipment_type\'\'image_label\'\'small_image_label\'\'thumbnail_label\');

For Magento 1.4.x run this query:

UPDATE catalog_eav_attribute SET used_in_product_listing=1 WHERE attribute_id IN (SELECT attribute_id FROM eav_attribute INNER JOIN eav_entity_type USING(entity_type_idWHERE entity_type_code=\'catalog_product\' AND attribute_code IN (\'name\'\'description\'\'short_description\'\'price\'\'special_price\'\'special_from_date\'\'special_to_date\'\'image\'\'small_image\'\'thumbnail\'\'status\'\'tax_class_id\'\'url_key\'\'required_options\'\'price_type\'\'weight_type\'\'price_view\'\'shipment_type\'\'image_label\'\'small_image_label\'\'thumbnail_label\'));

Refresh Magento cache.

 
Magento Community Magento Community
Magento Community
Magento Community
 
CollinsHarper
Jr. Member
 
Avatar
Total Posts:  18
Joined:  2008-08-14
Vancouver, BC
 

I found a fix for the images:

app/code/core/Mage/Catalog/Model/Convert/Adapter/Product.php

right around 697 you’ll see

$product->addImageToMediaGallery(Mage::getBaseDir('media') . DS 'import' $file$fields);

but it should be:

$product->addImageToMediaGallery(Mage::getBaseDir('media') . DS 'import' DS $file$fields);

Working on the qty issue now....

 
Magento Community Magento Community
Magento Community
Magento Community
 
bappa06
Jr. Member
 
Total Posts:  23
Joined:  2012-10-18
 

Thanks Daynos

Worked for me

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 3 of 3