Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 2 of 4
SOLVED: New order payment type just for the admin…or a real order edit
 
davedavedave
Sr. Member
 
Avatar
Total Posts:  238
Joined:  2007-08-31
 

Oops!  Tried again, and at least wasn’t getting any blank pages...but nothing seemed to be writing to system.log, even though it’s enabled.  Zero total checkout is also enabled.  Any ideas?

 
Magento Community Magento Community
Magento Community
Magento Community
 
medlington
Sr. Member
 
Total Posts:  143
Joined:  2008-04-30
 

any progress?

I need to add this option too

 
Magento Community Magento Community
Magento Community
Magento Community
 
medlington
Sr. Member
 
Total Posts:  143
Joined:  2008-04-30
 

cracked it using Trelayans method,

only thing that wasnt working for me was that there was too many admins in the URL within the php;

if (preg_match("|^/index.php/admin/admin/sales_order_create/|", $_SERVER[’REQUEST_URI’])) {

should have been

if (preg_match("|^/index.php/admin/sales_order_create/|", $_SERVER[’REQUEST_URI’])) {

and it works fine,

Thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
medlington
Sr. Member
 
Total Posts:  143
Joined:  2008-04-30
 

Does anyone know how I can change the text that is printed in the order which now says ‘No payment required’?

I need to change it to ‘payment already received’ or similar.

any ideas?

Thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
davedavedave
Sr. Member
 
Avatar
Total Posts:  238
Joined:  2007-08-31
 
medlington - 21 May 2009 01:10 AM

Does anyone know how I can change the text that is printed in the order which now says ‘No payment required’?

I need to change it to ‘payment already received’ or similar.

any ideas?

Thanks

Go to system > configuration > payment methods

Under zero subtotal checkout you can change the name

 
Magento Community Magento Community
Magento Community
Magento Community
 
davedavedave
Sr. Member
 
Avatar
Total Posts:  238
Joined:  2007-08-31
 

Just the one admin worked perfectly, thanks everybody.  I’ve edited the first post to show the solved version.

 
Magento Community Magento Community
Magento Community
Magento Community
 
rune00
Member
 
Total Posts:  39
Joined:  2008-08-03
 

I’m glad to finally find a post addressing one of my biggest concerns with Magento.

I copy/pasted the code and everything works fine after I removed /direct/ from the link.

In addition I added /index.php/admin/admin/sales_order_edit/ to the regex in order to edit already placed orders.

Thanks for the contribution guys smile

 
Magento Community Magento Community
Magento Community
Magento Community
 
ZeusSOM
Member
 
Total Posts:  69
Joined:  2009-01-25
 

I can’t seem to get this to work.  I followed exactly but once I add products to the order and the subtotal is no longer 0 the option goes away.  Can someone please help me with this?

I have tried both having the direct link in there and tried taking it out and it didn’t make a difference.

 
Magento Community Magento Community
Magento Community
Magento Community
 
rune00
Member
 
Total Posts:  39
Joined:  2008-08-03
 

ZeusSOM: I had the same problem. If the grep_match function doesn’t to match the URL it will not return true and thereby not show the payment option. Please check the URL and the preg_match function.

 
Magento Community Magento Community
Magento Community
Magento Community
 
ZeusSOM
Member
 
Total Posts:  69
Joined:  2009-01-25
 
rune00 - 27 June 2009 12:35 PM

ZeusSOM: I had the same problem. If the grep_match function doesn’t to match the URL it will not return true and thereby not show the payment option. Please check the URL and the preg_match function.

I thought I did this right:

“if (preg_match("|^/index.php/admin/admin/sales_order_create/|", $_SERVER[’REQUEST_URI’])) {

index.php/admin might be wrong. To check this, turn on your Magento logging mechanism and
enter the following code before the preg_match:

Mage::log("URI: “ . $_SERVER[’REQUEST_URI’]);

Then check your log and post if back here if it’s not sensitive info. “

However, when I checked my logs in var/report the most recently log was from like a few days ago.  I can’t seem to get any of this working.  What part of that URL would be wrong, is there any way to check it manually?

I assume where it says admin you put whatever your word is to get into the administration area, I of course use a custom one. But why is the other guy using direct in front and someone else isn’t?

Could cache be an issue?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Akidallar
Jr. Member
 
Total Posts:  18
Joined:  2009-05-11
 

[quote][b]2009-08-13T14:30:41+00:00 DEBUG (7): URI: /checkout/onepage/
2009-08-13T14:30:42+00:00 DEBUG (7): URI: /checkout/onepage/saveBilling/
2009-08-13T14:31:00+00:00 DEBUG (7): URI: /checkout/onepage/
2009-08-13T14:31:02+00:00 DEBUG (7): URI: /checkout/onepage/saveBilling/
2009-08-13T14:34:22+00:00 DEBUG (7): URI: /checkout/onepage/
2009-08-13T14:34:24+00:00 DEBUG (7): URI: /checkout/onepage/saveBilling/
2009-08-13T14:35:14+00:00 DEBUG (7): URI: /checkout/onepage/
2009-08-13T14:35:16+00:00 DEBUG (7): URI: /checkout/onepage/saveBilling/[/b][/quote]

This is the code I get when I look at my log. I have set everything up in the backend of my site and tried everyone suggestions but still nothing showing. I have a feeling the reason for this is because I haven’t got a normal checkout process.

When a user comes to the checkout the only information we need to get is whether they need shipping or they are arranging it themselves. Then it would go to the review page and when their order hass been aproved by my client they will then be sent an invoice. I don’t mind keeping the payment method section in there I have tried everything to bypass it by setting payment to free but it didn’t work. If anyone can help me get this working or point me in the right direction that would be a great help.

cheers

 
Magento Community Magento Community
Magento Community
Magento Community
 
davedavedave
Sr. Member
 
Avatar
Total Posts:  238
Joined:  2007-08-31
 

Is there a way to get the “Payment already provided” form of payment when editing an order?

 
Magento Community Magento Community
Magento Community
Magento Community
 
beavis82
Jr. Member
 
Total Posts:  15
Joined:  2009-02-03
 

Hello,

We’ve been struggling with this issue for a few weeks now. In the end I downloaded a Cash On Delivery module and made some mods to it so that it is only accessible from the back end. I’ve also changed the module’s name to ManualCardPayment, so you should be able to install the Cash On Delivery module too if you like, and they should work fine on the same installation of Magento. I’ve attached the module to this post.

Once installed go to Payment Methods within the control panel and change the title of this module to whatever you like - ‘Payment Already Provided’, ‘Manual Payment’, ‘No Payment Required’ etc. etc.

I’ve been trying to follow this thread and it seems that the general way people are preventing the payment method appearing in the frontend is to check the calling URI.

This module doesn’t look at the URI of where the script is being called from in order to prevent it from showing in the frontend - it uses the following code instead:

protected $_canUseInternal true;
protected 
$_canUseCheckout false;

...works brilliantly for us in Magento version 1.3.2.4.

I hope this is useful to someone!

Si

File Attachments
ManualCardPayment.zip  (File Size: 11KB - Downloads: 868)
 
Magento Community Magento Community
Magento Community
Magento Community
 
dragosn
Jr. Member
 
Total Posts:  7
Joined:  2008-07-06
 
beavis82 - 25 January 2010 07:04 AM

Hello,

We’ve been struggling with this issue for a few weeks now. In the end I downloaded a Cash On Delivery module and made some mods to it so that it is only accessible from the back end. I’ve also changed the module’s name to ManualCardPayment, so you should be able to install the Cash On Delivery module too if you like, and they should work fine on the same installation of Magento. I’ve attached the module to this post.

Once installed go to Payment Methods within the control panel and change the title of this module to whatever you like - ‘Payment Already Provided’, ‘Manual Payment’, ‘No Payment Required’ etc. etc.

I’ve been trying to follow this thread and it seems that the general way people are preventing the payment method appearing in the frontend is to check the calling URI.

This module doesn’t look at the URI of where the script is being called from in order to prevent it from showing in the frontend - it uses the following code instead:

protected $_canUseInternal true;
protected 
$_canUseCheckout false;

...works brilliantly for us in Magento version 1.3.2.4.

I hope this is useful to someone!

Si

I’ve tried this on Magento ver. 1.3.2.4 as well, and it works as advertised.

Personally I find this solution more elegant than anything else suggested on this thread, partly because it leaves the zero checkout method available for purposes for which I believe it was intended in the first place, such as promotions, product giveaways, etc.

Thanks beavis82.

 
Magento Community Magento Community
Magento Community
Magento Community
 
beavis82
Jr. Member
 
Total Posts:  15
Joined:  2009-02-03
 

No problems, glad it helped someone out! smile

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 2 of 4